summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2017-02-22 11:26:26 +0000
committerAndrew Stubbs2017-02-22 11:26:26 +0000
commit0cd58eb5c662a0303dd8e10cc03f7ad76e544a52 (patch)
tree32fbc8e0e3d25f7bf6ac2a196357895eea0ad84c
downloadaur-0cd58eb5c662a0303dd8e10cc03f7ad76e544a52.tar.gz
1.2.0
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD46
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a2d053a8895
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Feb 22 11:24:03 UTC 2017
+pkgbase = mimic
+ pkgdesc = Text-to-speech voice synthesis from the Mycroft project.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://mimic.mycroft.ai/
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = git
+ makedepends = libtool
+ makedepends = autoconf
+ makedepends = automake
+ depends = alsa-lib
+ source = mimic-1.2.0.tar.gz::https://github.com/MycroftAI/mimic/archive/1.2.0.tar.gz
+ md5sums = 6bd2a4e2349a8491542b2fd7739c67b8
+
+pkgname = mimic
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a59bb0d07c21
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.xz
+/*.gz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d84451e1c97f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
+pkgname=mimic
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Text-to-speech voice synthesis from the Mycroft project."
+arch=(x86_64 i686)
+url="https://mimic.mycroft.ai/"
+license=('custom')
+groups=()
+depends=(alsa-lib)
+makedepends=('git' 'libtool' 'autoconf' 'automake')
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/MycroftAI/mimic/archive/${pkgver}.tar.gz")
+noextract=()
+md5sums=('6bd2a4e2349a8491542b2fd7739c67b8')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+build() {
+ # mimic does not support building with BUILDDIR set
+ # (yaourt does this)
+ unset BUILDDIR
+
+ cd "$srcdir/$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+
+ #make
+ # Temporary workaround for https://github.com/MycroftAI/mimic/issues/95
+ make CFLAGS='-D_DEFAULT_SOURCE -O2'
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}