summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2016-02-26 11:29:28 +0000
committerAndrew Stubbs2016-02-26 11:29:28 +0000
commit42b8243711d8b81a33fbdfbe5da18ac0abb1925f (patch)
tree0bc0abc787aa7a123e07a776ed47dd1150672b9e
downloadaur-42b8243711d8b81a33fbdfbe5da18ac0abb1925f.tar.gz
New package.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32c14b66b0c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 26 11:27:27 UTC 2016
+pkgbase = mimic-git
+ pkgdesc = Text-to-speech voice synthesis from the Mycroft project.
+ pkgver = r28.8e28e5b
+ pkgrel = 1
+ url = https://mimic.mycroft.ai/
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = git
+ depends = alsa-lib
+ provides = mimic
+ conflicts = mimic
+ source = mimic::git+https://github.com/MycroftAI/mimic.git#branch=master
+ md5sums = SKIP
+
+pkgname = mimic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..148f9dfe0af7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
+pkgname=mimic-git
+pkgver=r28.8e28e5b
+pkgrel=1
+pkgdesc="Text-to-speech voice synthesis from the Mycroft project."
+arch=(x86_64 i686)
+url="https://mimic.mycroft.ai/"
+license=('custom')
+groups=()
+depends=(alsa-lib)
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('mimic::git+https://github.com/MycroftAI/mimic.git#branch=master')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# Git, tags available
+# printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ #./configure --prefix=/usr --with-audio=pulseaudio
+ ./configure --prefix=/usr --with-audio=alsa
+ make
+}
+
+#check() {
+# cd "$srcdir/${pkgname%-git}"
+# make -k test
+#}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+}