summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2017-05-01 14:38:49 +0200
committerWilliam Gathoye2017-05-01 14:38:49 +0200
commit76ead0dc0c8f4abde8b238f84f38a8258b112de4 (patch)
treef9e123f25542ed5e8ecfcc462cf76521e9edd157
downloadaur-76ead0dc0c8f4abde8b238f84f38a8258b112de4.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a05749da4d99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mimipenguin-git
+ pkgdesc = A tool to dump the login password from the current linux user
+ pkgver = r102.d69cc00
+ pkgrel = 1
+ url = https://github.com/huntergregal/mimipenguin
+ arch = any
+ license = CCPL:by
+ makedepends = git
+ depends = python
+ provides = mimipenguin
+ conflicts = mimipenguin
+ source = git+https://github.com/huntergregal/mimipenguin
+ sha512sums = SKIP
+
+pkgname = mimipenguin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a676d08ec44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: William Gathoye <william + aur at gathoye dot be>
+# Contributor:
+
+pkgname=mimipenguin-git
+pkgver=r102.d69cc00
+pkgrel=1
+pkgdesc="A tool to dump the login password from the current linux user"
+arch=('any')
+
+url="https://github.com/huntergregal/mimipenguin"
+license=('CCPL:by')
+
+makedepends=(
+ 'git'
+)
+depends=(
+ 'python'
+)
+provides=('mimipenguin')
+conflicts=('mimipenguin')
+
+source=('git+https://github.com/huntergregal/mimipenguin')
+sha512sums=('SKIP')
+
+# Get the number of revisions since beginning of the history
+# src.: https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+
+ cd "${pkgname%-git}"
+
+ # Force use of python3.
+ sed -i 's/python2 -c "import crypt; print crypt.crypt($CRYPT)"/python -c "import crypt; print(crypt.crypt($CRYPT))"/g' mimipenguin.sh
+}
+
+package() {
+ # When entering here, we are in the src directory, go in the cloned
+ # mimipenguin directory.
+ cd "${pkgname%-git}"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/license/mimipenguin/LICENSE"
+ install -Dm755 mimipenguin.py "$pkgdir/usr/bin/mimipenguin.py"
+ install -Dm755 mimipenguin.sh "$pkgdir/usr/bin/mimipenguin.sh"
+}