summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit21b155c5f10d18efd269ef2a338c36209d68ad58 (patch)
tree22fee5adfaf0d39ac4ed785352de12452d3fd5e7
downloadaur-21b155c5f10d18efd269ef2a338c36209d68ad58.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8db78e501887
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mimms
+ pkgdesc = Download streams using the MMS protocol and save them to your computer
+ pkgver = 3.2.1
+ pkgrel = 2
+ url = http://savannah.nongnu.org/projects/mimms/
+ arch = any
+ license = GPL3
+ depends = libmms
+ depends = python2
+ source = http://download.savannah.gnu.org/releases/mimms/mimms-3.2.1.tar.bz2
+ md5sums = ec629d8899551b4789ba15c17402c36f
+
+pkgname = mimms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5ca05a9bf4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=mimms
+pkgver=3.2.1
+pkgrel=2
+pkgdesc="Download streams using the MMS protocol and save them to your computer"
+arch=('any')
+url="http://savannah.nongnu.org/projects/mimms/"
+license=('GPL3')
+depends=('libmms' 'python2')
+source=(http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2)
+md5sums=('ec629d8899551b4789ba15c17402c36f')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+#Python2 fix
+ sed -i "s/python/python2/g" Makefile
+
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ make DESTDIR=${pkgdir} install
+} \ No newline at end of file