summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblooser2019-01-12 21:22:15 +0100
committerblooser2019-01-12 21:22:15 +0100
commit73119586e88da0d2139c63436a92dce8915f9eab (patch)
treef9569dfb8861e23645fd9a02d0f54f585ea0e163
downloadaur-73119586e88da0d2139c63436a92dce8915f9eab.tar.gz
Initialize
Signed-off-by: blooser <Blooser@protonmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD49
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f08ccbf95d0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mimosa
+ pkgdesc = Download manager
+ pkgver = 1.1.1
+ pkgrel = 4
+ url = https://github.com/blooser/mimosa
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = qt5-base
+ source = https://github.com/blooser/mimosa/archive/v1.1.1.tar.gz
+ md5sums = b0cdb9921560264d423d26f3777a3d29
+
+pkgname = mimosa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a38821858269
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Blooser <blooser@protonmail.com>
+pkgname=mimosa
+pkgver=1.1.1
+pkgrel=4
+pkgdesc="Download manager"
+arch=('x86_64')
+md5sums=('b0cdb9921560264d423d26f3777a3d29')
+url="https://github.com/blooser/mimosa"
+license=('MIT')
+depends=('qt5-base')
+makedepends=('cmake')
+applocation=~/Documents/$pkgname
+shortcut="
+[Desktop Entry]
+Encoding=UTF-8
+Version=${pkgver}
+Name[en_US]=Mimosa
+GenericName=Download manager
+Exec=${applocation}/mimosa
+Icon[en_US]=${applocation}/icons/mimosa.png
+Type=Application
+Categories=Application;Network
+Comment[en_US]=Take a glance at your downloads from the Internet
+"
+
+source=("https://github.com/blooser/mimosa/archive/v${pkgver}.tar.gz")
+
+build() {
+ cd $pkgname-$pkgver
+ qmake
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make clean
+ cd ..
+ mv $pkgname-$pkgver $pkgname
+ cp -r $pkgname ~/Documents
+ rm -rf $pkgname
+ echo "${shortcut}" > ~/.local/share/applications/mimosa.desktop
+ if [ -f ~/.zshrc ]; then
+ echo "alias mimosa=${applocation}/mimosa" >> ~/.zshrc
+ else
+ echo "alias mimosa=${applocation}/mimosa" >> ~/.bashrc
+ fi
+
+}
+