summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinuxSEAT2015-07-24 01:13:07 +0300
committerlinuxSEAT2015-07-24 01:13:07 +0300
commita0e5e429090cfe265ad8f3069e4e87f1dcb38e88 (patch)
tree7edf8fee83066564d180c17cb882f21830da2c9f
downloadaur-a0e5e429090cfe265ad8f3069e4e87f1dcb38e88.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
-rw-r--r--minbar.install21
-rw-r--r--minbar.patch51
4 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47e43941ad87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = minbar
+ pkgdesc = Islamic prayer times and athan for GNOME
+ pkgver = 0.2.1
+ pkgrel = 8
+ url = http://djihed.com/minbar
+ install = minbar.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libitl
+ depends = libgnomecanvas
+ depends = gstreamer0.10
+ depends = libnotify
+ depends = gconf
+ depends = hicolor-icon-theme
+ depends = rarian
+ optdepends = xfce4-xfapplet-plugin: adds Xfce4 panel support
+ source = http://files.djihed.com/minbar/minbar-0.2.1.tar.bz2
+ source = minbar.patch
+ md5sums = dd1543a2e6cc9873d39d60b61dec7508
+ md5sums = 7b28640c6797c15bfc31b3a3be8ff27d
+
+pkgname = minbar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9d6506daabc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: linuxSEAT <--put_my_name_here--@gmail.com>
+
+pkgname=minbar
+pkgver=0.2.1
+pkgrel=8
+pkgdesc="Islamic prayer times and athan for GNOME"
+url="http://djihed.com/minbar"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=(libitl libgnomecanvas gstreamer0.10 libnotify gconf hicolor-icon-theme
+rarian)
+optdepends=('xfce4-xfapplet-plugin: adds Xfce4 panel support')
+install=$pkgname.install
+source=(http://files.djihed.com/minbar/$pkgname-$pkgver.tar.bz2
+ minbar.patch)
+md5sums=('dd1543a2e6cc9873d39d60b61dec7508'
+ '7b28640c6797c15bfc31b3a3be8ff27d')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ LDFLAGS="-lm"
+ patch -p1 -i ../minbar.patch || return 1
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR=${pkgdir} install
+}
diff --git a/minbar.install b/minbar.install
new file mode 100644
index 000000000000..9f59f0570253
--- /dev/null
+++ b/minbar.install
@@ -0,0 +1,21 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+pre_upgrade() {
+ if [ -f /usr/share/gconf/schemas/minbar.schemas ]; then
+ gconfpkg --uninstall minbar
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ post_install $1
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
diff --git a/minbar.patch b/minbar.patch
new file mode 100644
index 000000000000..b57a2d3b87c0
--- /dev/null
+++ b/minbar.patch
@@ -0,0 +1,51 @@
+diff -rupN minbar-0.2.1/configure.ac minbar-0.2.1-updated/configure.ac
+--- minbar-0.2.1/configure.ac 2007-12-23 19:08:23.000000000 +0300
++++ minbar-0.2.1-updated/configure.ac 2013-03-25 05:31:04.520442632 +0300
+@@ -34,6 +34,9 @@ pkg_modules="gtk+-2.0 >= 2.10 glib-2.0 l
+ PKG_CHECK_MODULES(MINBAR, [$pkg_modules])
+
+ AC_CHECK_HEADER(itl/prayer.h,ITL_LIBS=-litl,AC_MSG_ERROR("itl/prayer.h not found."))
++
++LDFLAGS="$LDFLAGS -L/usr/lib/itl -Xlinker -rpath -Xlinker /usr/lib/itl"
++
+ AC_SUBST(ITL_LIBS)
+
+ # libnotify check
+diff -rupN minbar-0.2.1/src/locations-xml.c minbar-0.2.1-updated/src/locations-xml.c
+--- minbar-0.2.1/src/locations-xml.c 2007-11-17 18:35:19.000000000 +0300
++++ minbar-0.2.1-updated/src/locations-xml.c 2013-03-25 04:51:27.667225033 +0300
+@@ -17,6 +17,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <ctype.h>
+ #include <string.h>
+ #include <math.h>
+ #include <locale.h>
+diff -rupN minbar-0.2.1/src/main.c minbar-0.2.1-updated/src/main.c
+--- minbar-0.2.1/src/main.c 2007-12-23 19:08:24.000000000 +0300
++++ minbar-0.2.1-updated/src/main.c 2013-03-25 04:54:06.986663140 +0300
+@@ -1256,12 +1256,8 @@ void show_notification(gchar * message)
+
+ void create_notification()
+ {
+- notification = notify_notification_new
+- (program_name,
+- NULL,
+- NULL,
+- NULL);
+- notify_notification_attach_to_status_icon (notification, status_icon );
++ notification = notify_notification_new (program_name, NULL, NULL);
++// notify_notification_attach_to_status_icon (notification, status_icon );
+ notify_notification_set_timeout (notification, 8000);
+ }
+ #endif
+@@ -1397,7 +1393,7 @@ void calculate_qibla_direction()
+ gtk_widget_set_direction ((GtkWidget*)canvas, GTK_TEXT_DIR_RTL);
+ gnome_canvas_set_pixels_per_unit((GnomeCanvas*) canvas, 1);
+
+- root = gnome_canvas_root (GNOME_CANVAS (canvas));
++ root = gnome_canvas_root (canvas);
+
+ double height = (double) GTK_WIDGET (canvas)->allocation.height;
+ double width = (double) GTK_WIDGET (canvas)->allocation.width;