summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-04-25 19:47:19 +0200
committerMartino Pilia2018-04-25 19:47:19 +0200
commit7bb42fe5db92cdaf0c5828f645b79c4efba4f5bc (patch)
tree9d395d6a29a4b1b72f36ed572f28f4dc56b377a0
parent3f9b00b79a0f4f4cc611eff8996099e169a71198 (diff)
downloadaur-7bb42fe5db92cdaf0c5828f645b79c4efba4f5bc.tar.gz
use ANTs package from AUR
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a42f79dd5fc8..7b7b97a88f4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = minc-toolkit-v2
pkgdesc = Medical Imaging NetCDF Toolkit
pkgver = 1.9.16
- pkgrel = 1
+ pkgrel = 2
url = https://www.mcgill.ca/bic/software/minc
arch = any
license = GPL3
@@ -26,6 +26,7 @@ pkgbase = minc-toolkit-v2
depends = elastix
depends = lapacke
depends = blas
+ depends = ants
provides = minc-toolkit
source = git+https://github.com/BIC-MNI/minc-toolkit-v2.git
source = FindNIFTI.patch
diff --git a/PKGBUILD b/PKGBUILD
index 3b90fb27ecae..2376bb48a75b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
pkgname=minc-toolkit-v2
pkgver=1.9.16
-pkgrel=1
+pkgrel=2
pkgdesc="Medical Imaging NetCDF Toolkit"
arch=('any')
url="https://www.mcgill.ca/bic/software/minc"
license=('GPL3')
-depends=('perl' 'libjpeg-turbo' 'libxi' 'libxmu' 'libgl' 'glu' 'fftw' 'glut' 'netcdf' 'pcre' 'zlib' 'hdf5' 'nifticlib' 'insight-toolkit' 'elastix' 'lapacke' 'blas')
+depends=('perl' 'libjpeg-turbo' 'libxi' 'libxmu' 'libgl' 'glu' 'fftw' 'glut' 'netcdf' 'pcre' 'zlib' 'hdf5' 'nifticlib' 'insight-toolkit' 'elastix' 'lapacke' 'blas' 'ants')
makedepends=('git' 'cmake' 'bc' 'libhdf5')
provides=('minc-toolkit')
source=('git+https://github.com/BIC-MNI/minc-toolkit-v2.git'
@@ -107,7 +107,7 @@ prepare() {
-DCMAKE_BUILD_TYPE:STRING=Release \
-DCMAKE_INSTALL_PREFIX:PATH="${_install_prefix}" \
-DMT_BUILD_ABC:BOOL=ON \
- -DMT_BUILD_ANTS:BOOL=ON \
+ -DMT_BUILD_ANTS:BOOL=OFF \
-DMT_BUILD_C3D:BOOL=ON \
-DMT_BUILD_ELASTIX:BOOL=OFF \
-DMT_BUILD_IM:BOOL=OFF \
@@ -116,6 +116,7 @@ prepare() {
-DMT_BUILD_SHARED_LIBS:BOOL=ON \
-DMT_BUILD_VISUAL_TOOLS:BOOL=ON \
-DMT_USE_OPENMP:BOOL=ON \
+ -DUSE_SYSTEM_ANTS:BOOL=ON \
-DUSE_SYSTEM_ELASTIX:BOOL=ON \
-DUSE_SYSTEM_FFTW3D:BOOL=ON \
-DUSE_SYSTEM_FFTW3F:BOOL=ON \