summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2020-04-22 14:52:27 -0400
committerbrent s2020-04-22 14:52:27 -0400
commit763613830829650e387b600e9599bd9cccb8245f (patch)
treeb5ad15b288b9ac60f4a9f54900021751aa6a84ad
parent8ad1fb21eb468a6e3db07029f2100009aa487fa2 (diff)
downloadaur-mindi-busybox.tar.gz
bumping to 1.25.1 and wrote patch for glibc stime shit (https://bugs.gentoo.org/708350)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
-rw-r--r--dhcpc.patch20
-rw-r--r--dhcpc.patch.sigbin566 -> 0 bytes
-rw-r--r--glibc_stime.patch66
-rw-r--r--glibc_stime.patch.sigbin0 -> 566 bytes
-rw-r--r--mindi-busybox-1.21.1.tar.gz.sigbin566 -> 0 bytes
-rw-r--r--mindi-busybox-1.25.1.tar.gz.sigbin0 -> 566 bytes
8 files changed, 83 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e344c46572e5..2ac1b6520fa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = mindi-busybox
pkgdesc = This package provides a busybox version suited for Mindi
- pkgver = 1.21.1
- pkgrel = 2
+ pkgver = 1.25.1
+ pkgrel = 1
url = http://www.mondorescue.org/
arch = i686
arch = x86_64
license = GPL
depends = gcc
- source = ftp://ftp.mondorescue.org/src/mindi-busybox-1.21.1.tar.gz
- source = dhcpc.patch
- source = mindi-busybox-1.21.1.tar.gz.sig
- source = dhcpc.patch.sig
+ source = ftp://ftp.mondorescue.org/src/mindi-busybox-1.25.1.tar.gz
+ source = glibc_stime.patch
+ source = mindi-busybox-1.25.1.tar.gz.sig
+ source = glibc_stime.patch.sig
validpgpkeys = 748231EBCBD808A14F5E85D28C004C2F93481F6B
- sha512sums = 6205e16585604c7b3c55a9b5677dc42e60bf4d63d08b2c4feb6511cf1ec11a70820732c89706ad99dbd4d506a2146581a7fd7f33426a9d41ecdc6dfef1ded10f
- sha512sums = ba1d110e4207481d02f05cc5e79b927270439c97d1ec1455e5a173c903fed7fd91cc0953279873da61fe4a7b4b8a51e29ab48d2d531be3d2b861d92586728b3d
+ sha512sums = 56cfa5c95a2527022884e3ac7bcfe43cb95df12f162f2c1988003763d30dacfc3215ff87ffd11712e60114d390d211d9da4adf4da25456f8a01f6c19b479ccbc
+ sha512sums = a95c18ad3ea7b312d1da14edc75de45a4d1f86374258711eea6bf7f9d007e758a95b7cee0d5e45bf99d1c2f29dfe29dff238e1c5a44723761cf2b554f888913e
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8aebd8539c98..0aca21018e36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,10 @@
# News updates for packages can be followed at https://devblog.square-r00t.net
validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# Past maintainer: F. MiƱano <cicely@algofacil.info>
+# TODO: CC=musl-gcc instead?
pkgname=mindi-busybox
-pkgver=1.21.1
-pkgrel=2
+pkgver=1.25.1
+pkgrel=1
pkgdesc="This package provides a busybox version suited for Mindi"
arch=('i686' 'x86_64')
url="http://www.mondorescue.org/"
@@ -14,17 +15,17 @@ depends=(gcc)
#There are two official mirrors. If one is not working try the other. The muskokamug.org seems faster.
source=("ftp://ftp.mondorescue.org/src/${pkgname}-${pkgver}.tar.gz"
- "dhcpc.patch"
+ "glibc_stime.patch"
"${pkgname}-${pkgver}.tar.gz.sig"
- "dhcpc.patch.sig")
-sha512sums=('6205e16585604c7b3c55a9b5677dc42e60bf4d63d08b2c4feb6511cf1ec11a70820732c89706ad99dbd4d506a2146581a7fd7f33426a9d41ecdc6dfef1ded10f'
- 'ba1d110e4207481d02f05cc5e79b927270439c97d1ec1455e5a173c903fed7fd91cc0953279873da61fe4a7b4b8a51e29ab48d2d531be3d2b861d92586728b3d'
- 'SKIP'
+ "glibc_stime.patch.sig")
+sha512sums=('56cfa5c95a2527022884e3ac7bcfe43cb95df12f162f2c1988003763d30dacfc3215ff87ffd11712e60114d390d211d9da4adf4da25456f8a01f6c19b479ccbc'
+ 'a95c18ad3ea7b312d1da14edc75de45a4d1f86374258711eea6bf7f9d007e758a95b7cee0d5e45bf99d1c2f29dfe29dff238e1c5a44723761cf2b554f888913e'
+ 'SKIP'
'SKIP')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < ${srcdir}/dhcpc.patch
+ patch -p1 < ${srcdir}/glibc_stime.patch
}
build() {
diff --git a/dhcpc.patch b/dhcpc.patch
deleted file mode 100644
index a1edeb4b58d9..000000000000
--- a/dhcpc.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Much thanks to Richard Neumann <r(dot)neumann(at)homeinfo(dot)de> for this patch. -bts
-===================================================================
---- a/networking/udhcp/dhcpc.c 2017-08-04 11:24:43.813167030 +0200
-+++ b/networking/udhcp/dhcpc.c 2017-08-04 11:27:18.137996999 +0200
-@@ -26,13 +26,8 @@
- #include "dhcpc.h"
-
- #include <asm/types.h>
--#if (defined(__GLIBC__) && __GLIBC__ >= 2 && __GLIBC_MINOR__ >= 1) || defined(_NEWLIB_VERSION)
--# include <netpacket/packet.h>
--# include <net/ethernet.h>
--#else
--# include <linux/if_packet.h>
--# include <linux/if_ether.h>
--#endif
-+#include <linux/if_packet.h>
-+#include <linux/if_ether.h>
- #include <linux/filter.h>
-
- /* "struct client_config_t client_config" is in bb_common_bufsiz1 */
diff --git a/dhcpc.patch.sig b/dhcpc.patch.sig
deleted file mode 100644
index 0c9416b04082..000000000000
--- a/dhcpc.patch.sig
+++ /dev/null
Binary files differ
diff --git a/glibc_stime.patch b/glibc_stime.patch
new file mode 100644
index 000000000000..4c8bf4c75dee
--- /dev/null
+++ b/glibc_stime.patch
@@ -0,0 +1,66 @@
+# adapted from https://708350.bugs.gentoo.org/attachment.cgi?id=611780
+diff a/coreutils/date.c b/coreutils/date.c
+--- a/coreutils/date.c
++++ b/coreutils/date.c
+@@ -268,6 +268,9 @@
+ time(&ts.tv_sec);
+ #endif
+ }
++#if !ENABLE_FEATURE_DATE_NANO
++ ts.tv_nsec = 0;
++#endif
+ localtime_r(&ts.tv_sec, &tm_time);
+
+ /* If date string is given, update tm_time, and maybe set date */
+@@ -290,11 +293,12 @@
+ if (date_str[0] != '@')
+ tm_time.tm_isdst = -1;
+ ts.tv_sec = validate_tm_time(date_str, &tm_time);
++ ts.tv_nsec = 0;
+
+ maybe_set_utc(opt);
+
+ /* if setting time, set it */
+- if ((opt & OPT_SET) && stime(&ts.tv_sec) < 0) {
++ if ((opt & OPT_SET) && clock_settime(CLOCK_REALTIME, &ts) < 0) {
+ bb_perror_msg("can't set date");
+ }
+ }
+diff a/libbb/missing_syscalls.c b/libbb/missing_syscalls.c
+--- a/libbb/missing_syscalls.c
++++ b/libbb/missing_syscalls.c
+@@ -16,14 +16,6 @@
+ return syscall(__NR_getsid, pid);
+ }
+
+-int stime(const time_t *t)
+-{
+- struct timeval tv;
+- tv.tv_sec = *t;
+- tv.tv_usec = 0;
+- return settimeofday(&tv, NULL);
+-}
+-
+ int sethostname(const char *name, size_t len)
+ {
+ return syscall(__NR_sethostname, name, len);
+diff a/util-linux/rdate.c b/util-linux/rdate.c
+--- a/util-linux/rdate.c
++++ b/util-linux/rdate.c
+@@ -67,9 +67,13 @@
+ time(&current_time);
+ if (current_time == remote_time)
+ bb_error_msg("current time matches remote time");
+- else
+- if (stime(&remote_time) < 0)
+- bb_perror_msg_and_die("can't set time of day");
++ else {
++ struct timespec ts;
++ ts.tv_sec = remote_time;
++ ts.tv_nsec = 0;
++ if (clock_settime(CLOCK_REALTIME, &ts) < 0)
++ bb_perror_msg_and_die("can't set time of day");
++ }
+ }
+
+ if (flags != 1) /* not lone -s */
diff --git a/glibc_stime.patch.sig b/glibc_stime.patch.sig
new file mode 100644
index 000000000000..c01b8411ded5
--- /dev/null
+++ b/glibc_stime.patch.sig
Binary files differ
diff --git a/mindi-busybox-1.21.1.tar.gz.sig b/mindi-busybox-1.21.1.tar.gz.sig
deleted file mode 100644
index bdfe72cd1488..000000000000
--- a/mindi-busybox-1.21.1.tar.gz.sig
+++ /dev/null
Binary files differ
diff --git a/mindi-busybox-1.25.1.tar.gz.sig b/mindi-busybox-1.25.1.tar.gz.sig
new file mode 100644
index 000000000000..583a20e79555
--- /dev/null
+++ b/mindi-busybox-1.25.1.tar.gz.sig
Binary files differ