summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2016-01-18 15:05:05 -0500
committerbrent s2016-01-18 15:05:05 -0500
commit4a3c790068886dd2fe797936245ba76884c63a15 (patch)
tree96a660374709c3cd560f2f6560de8cca69d05b1c
parent2586a48f5bbfe65482e15b8f5bcc7c325a02b23a (diff)
downloadaur-4a3c790068886dd2fe797936245ba76884c63a15.tar.gz
pkgbuild cleanup
-rw-r--r--.SRCINFO5
-rw-r--r--ChangeLog53
-rw-r--r--PKGBUILD15
3 files changed, 9 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61dc14636426..c7737a7aff81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 20:05:05 UTC 2016
pkgbase = mindi-busybox
pkgdesc = This package provides a busybox version suited for Mindi
pkgver = 1.18.5
- pkgrel = 2
+ pkgrel = 3
url = http://www.mondorescue.org/
- changelog = ChangeLog
arch = i686
arch = x86_64
license = GPL
diff --git a/ChangeLog b/ChangeLog
deleted file mode 100644
index 28fac6ade9f8..000000000000
--- a/ChangeLog
+++ /dev/null
@@ -1,53 +0,0 @@
-# $Id$
-
-MINDI-BUSYBOX CHANGES
-
-1.18.5-1 (2011-12-23)
-- Adds support for SUID binaries (Bruno Cornec)
-- Fix #499 for good, by using a real init from busybox and moving our init script to etc/init.d/rcS. We also now call the reboot from busybox to exit, which indeed reset the system correctly (in a VM at least which wasn't the case before). Requires a new mindi-busybox as well. (Bruno Cornec)
-- Fixes the shell msg error by using setsid as per Busybox FAQ (Bruno Cornec)
-- Update to upstream busybox 1.18.5 (Bruno Cornec)
-
-1.18.3-3 (2011-06-27)
-- Adds the swapon feature to mindi-busybox (Bruno Cornec)
-- Removes telinit call in busybox to try to fix problems when reboot at end of restore (Bruno Cornec)
-- Addes an extraversion for revision support (Bruno Cornec)
-- Adds support for ifconfig and ping for PXE+NFS boot for this version of mindi-busybox (Bruno Cornec)
-- Adds support for MT back mandatory for OBDR (Bruno Cornec)
-
-1.18.3-2 (2011-04-12)
-- Remove blkid from busybox to solve #435 (Bruno Cornec)
-
-1.18.3-1 (2011-02-27)
-- Updated based on busybox 1.18.3 to solve tar issues with latest RHEL 6 e.g. (Bruno Cornec)
-
-1.7.3-1 (2008-03-22)
-- Updated based on busybox 1.7.3 (Bruno Cornec)
-- Fix gentoo installation issue (Francesco Talamona/Bruno Cornec)
-- remove MONOTONIC clock to continue to support 2.4 kernels (RHEL 3 e.g. or ESX) (Bruno Cornec)
-- Adds dd support for swap partition label (Bruno Cornec)
-- Try to add cttyhack to suppress an error message at shell level (Bruno Cornec)
-
-1.7.2-1 (2007-10-30)
-- Updated based on busybox 1.7.2 (Bruno Cornec)
-
-1.2.2-4 (2007-10-11)
-- Build process adapted to use pb (http://trac.project-builder.org) (Bruno Cornec)
-- Fix another issue in mindi-busybox gentoo's ebuild (Francesco Talamona)
-
-1.2.2-3 (2007-05-17)
-- Fix a blocking bug in mindi-busybox gentoo's ebuild (Francesco Talamona)
-
-1.2.2-2 (2007-04-08)
-- Improve Gentoo packaging (Linos)
-
-1.2.2 (2006-12-23)
-- mindi-busybox version is now extended with the SVN revision (Bruno Cornec)
-- Fix a known bug for busybox where -gc-section in makefile + static for link crea tes a buggy busybox with glibc (Bruno Cornec)
-- Updated based on busybox 1.2.2 (Bruno Cornec)
-- Handles modules back again (Bruno Cornec)
-- Fix bug #88 around install conflicts (Bruno Cornec)
-
-1.2.1 (2006-10-04)
-- Creation based on busybox 1.2.1 (Bruno Cornec)
-- Remove module management, bunzip2 in config file (Bruno Cornec)
diff --git a/PKGBUILD b/PKGBUILD
index e9ef92961d25..a23e3cc27f71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
-# Maintainer: F. Miñano <cicely@algofacil.info>
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+# Past maintainer: F. Miñano <cicely@algofacil.info>
pkgname=mindi-busybox
pkgver=1.18.5
-pkgrel=2
+pkgrel=3
pkgdesc="This package provides a busybox version suited for Mindi"
arch=('i686' 'x86_64')
url="http://www.mondorescue.org/"
license=('GPL')
depends=(gcc)
-changelog=ChangeLog
#There are two official mirrors. If one is not working try the other. The muskokamug.org seems faster.
-source=(ftp://ftp.mondorescue.org/src/mindi-busybox-1.18.5.tar.gz)
-#source=(http://mondorescue.muskokamug.org/src/$pkgname-$pkgver.tar.gz)
+source=(ftp://ftp.mondorescue.org/src/${pkgname}-${pkgver}.tar.gz)
md5sums=('0668d3bba33989dbaab3f84771578438')
# 'ec7280e7573eb12cbb9cc6707468ef01')
package() {
- cd "$srcdir/$pkgname-$pkgver"
-# patch -p1 < ../shell_common.patch
+ cd "${srcdir}/${pkgname}-${pkgver}"
make oldconfig || return 1
make busybox || return 1
- make CONFIG_PREFIX=$pkgdir/usr/lib/mindi/rootfs install
+ make CONFIG_PREFIX=${pkgdir}/usr/lib/mindi/rootfs install
}
-# vim:set ts=2 sw=2 et: