summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Meleshko2019-10-10 21:56:44 +0300
committerDmytro Meleshko2019-10-10 21:56:44 +0300
commit67aefadb52d69c5de201a2044814d1d9b5b280b9 (patch)
tree2b8517073870d7f752b135f8e19e939e76f108ec
parent343d06867a69f36df1f4219d5b406a37d617117c (diff)
downloadaur-67aefadb52d69c5de201a2044814d1d9b5b280b9.tar.gz
download icon from upstream
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--mindustry-bin.desktop4
-rw-r--r--mindustry-bin.pngbin38242 -> 0 bytes
4 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 474179dc8ca6..27a207aadf45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,18 +5,20 @@ pkgbase = mindustry-bin
url = https://github.com/Anuken/Mindustry
arch = any
license = GPL3
+ makedepends = libicns
depends = java-runtime=8
depends = sh
+ depends = hicolor-icon-theme
conflicts = mindustry
replaces = mindustry
noextract = mindustry-bin-96.jar
source = mindustry-bin-96.jar::https://github.com/Anuken/Mindustry/releases/download/v96/Mindustry.jar
+ source = mindustry-bin.icns::https://github.com/Anuken/Mindustry/raw/master/core/assets/icons/icon.icns
source = mindustry-bin.desktop
- source = mindustry-bin.png
source = mindustry-bin.sh
sha256sums = 30d1f984c6924af1d22f7317819a42042393488ca53e7ceed509bab74f70304d
- sha256sums = 7fafd7598480293530e2d5c62abdbb7d37f40ed4d5fbae0bdeaae8d1167b5679
- sha256sums = b4ca7e8083ab1d5e63601a63378211c9def97333324e6c9b48acf4cfb83fa9e8
+ sha256sums = 16fcae782b13a8460e631d265c505f56393acd14700b016904744bd44aa290eb
+ sha256sums = e5fd49ed3456c53e91b834cb388956e3f9ded4e2c880352d36cf9c2246ca0f0b
sha256sums = 938f5f9f636379402ba0bb9a53345de499f4f3fd50f232b31605129dcf4ea6c9
pkgname = mindustry-bin
diff --git a/PKGBUILD b/PKGBUILD
index ca40ae8cdab7..e761fde10afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,32 @@ pkgdesc="A sandbox tower defense game written in Java"
arch=("any")
url="https://github.com/Anuken/Mindustry"
license=("GPL3")
-depends=("java-runtime=8" "sh")
+depends=("java-runtime=8" "sh" "hicolor-icon-theme")
+makedepends=("libicns")
# provides=(${_pkgname})
replaces=(${_pkgname})
conflicts=(${_pkgname})
source=("${pkgname}-${pkgver}.jar::https://github.com/Anuken/Mindustry/releases/download/v${pkgver}/Mindustry.jar"
+ "${pkgname}.icns::https://github.com/Anuken/Mindustry/raw/master/core/assets/icons/icon.icns"
"${pkgname}.desktop"
- "${pkgname}.png"
"${pkgname}.sh")
sha256sums=('30d1f984c6924af1d22f7317819a42042393488ca53e7ceed509bab74f70304d'
- '7fafd7598480293530e2d5c62abdbb7d37f40ed4d5fbae0bdeaae8d1167b5679'
- 'b4ca7e8083ab1d5e63601a63378211c9def97333324e6c9b48acf4cfb83fa9e8'
+ '16fcae782b13a8460e631d265c505f56393acd14700b016904744bd44aa290eb'
+ 'e5fd49ed3456c53e91b834cb388956e3f9ded4e2c880352d36cf9c2246ca0f0b'
'938f5f9f636379402ba0bb9a53345de499f4f3fd50f232b31605129dcf4ea6c9')
noextract=("${pkgname}-${pkgver}.jar")
+build() {
+ icns2png --extract "${pkgname}.icns"
+}
+
package() {
install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+ local icon_size; for icon_size in 256 512 1024; do
+ install -Dm644 "${pkgname}_${icon_size}x${icon_size}x32.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps/${_pkgname}.png"
+ done
install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm755 "${pkgname}-${pkgver}.jar" "${pkgdir}/usr/share/java/${_pkgname}/Mindustry.jar"
+
}
diff --git a/mindustry-bin.desktop b/mindustry-bin.desktop
index 3e1a21cadcfe..0c21085c629a 100644
--- a/mindustry-bin.desktop
+++ b/mindustry-bin.desktop
@@ -3,7 +3,7 @@ Version=1.0
Type=Application
Name=Mindustry
Comment=A sandbox tower defense game
-Exec=/usr/bin/mindustry
-Icon=/usr/share/pixmaps/mindustry.png
+Exec=mindustry
+Icon=mindustry
Categories=Game;
Terminal=false
diff --git a/mindustry-bin.png b/mindustry-bin.png
deleted file mode 100644
index 4cfed574e5ae..000000000000
--- a/mindustry-bin.png
+++ /dev/null
Binary files differ