summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheAirBlow2021-10-11 12:38:27 +0000
committerTheAirBlow2021-10-11 12:38:27 +0000
commitcec6206aaf70ea7b7e34e2a5e97a0009ae50e64e (patch)
tree8a011c558f9a1d7d4b7740feb4dec0e6929b3502
downloadaur-cec6206aaf70ea7b7e34e2a5e97a0009ae50e64e.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--mindustry-foos-client-bin.desktop9
-rwxr-xr-xmindustry-foos-client-bin.sh2
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb07ee880174
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mindustry-foos-client-bin
+pkgdesc = Client modification for Mindustry
+pkgver = 7.0_761
+pkgrel = 1
+epoch = 1
+url = https://github.com/mindustry-antigrief/mindustry-client
+arch = any
+license = GPL3
+makedepends = libicns
+depends = java-runtime>=8
+depends = sh
+depends = hicolor-icon-theme
+provides = mindustry-foos-client
+conflicts = mindustry-foos-client
+noextract = mindustry-foos-client-bin-761.jar
+source = mindustry-foos-client-bin-761.jar::https://github.com/mindustry-antigrief/mindustry-client-v7-builds/releases/download/761/desktop.jar
+source = mindustry-foos-client-bin.icns::https://github.com/mindustry-antigrief/mindustry-client/blob/v6/core/assets/icons/icon.icns
+source = mindustry-foos-client-bin.desktop
+source = mindustry-foos-client-bin.sh
+sha256sums = 3b877f309270685ce2ebaaca32ec6a4880aa6eb29fbfc7c7e7243b8ac60da202
+sha256sums = 47b09296c869a67312e209e5d528cbcfd01532edfc031dba7b6fe2170c2493b6
+sha256sums = a18724f42a2a79b129d1901a8b75a965a621eb5ef97698b05cf8addcf5948600
+sha256sums = 6827b29e2afc023089c4d46c6dde3fccf3ad01554ba6c22c20e7bce7a109224f
+pkgname = mindustry-foos-client-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dac141cc3cc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: TheAirBlow <pilexet.danila@gmail.com>
+_pkgname=mindustry-foos-client
+pkgname="${_pkgname}-bin"
+_build=761
+pkgver="7.0_${_build}"
+pkgrel=1
+epoch=1
+pkgdesc="Client modification for Mindustry"
+arch=("any")
+url="https://github.com/mindustry-antigrief/mindustry-client"
+license=("GPL3")
+depends=("java-runtime>=8" "sh" "hicolor-icon-theme")
+makedepends=("libicns")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("${pkgname}-${_build}.jar::https://github.com/mindustry-antigrief/mindustry-client-v7-builds/releases/download/761/desktop.jar"
+ "${pkgname}.icns::https://github.com/mindustry-antigrief/mindustry-client/blob/v6/core/assets/icons/icon.icns"
+ "${pkgname}.desktop"
+ "${pkgname}.sh")
+noextract=("${pkgname}-${_build}.jar")
+
+build() {
+ icns2png --extract "${pkgname}.icns"
+}
+
+package() {
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+ local icon_size; for icon_size in 256 512 1024; do
+ install -Dm644 "${pkgname}_${icon_size}x${icon_size}x32.png" "${pkgdir}/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps/${_pkgname}.png"
+ done
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm755 "${pkgname}-${_build}.jar" "${pkgdir}/usr/share/java/${_pkgname}/Mindustry.jar"
+}
+
+sha256sums=('3b877f309270685ce2ebaaca32ec6a4880aa6eb29fbfc7c7e7243b8ac60da202'
+ '47b09296c869a67312e209e5d528cbcfd01532edfc031dba7b6fe2170c2493b6'
+ 'a18724f42a2a79b129d1901a8b75a965a621eb5ef97698b05cf8addcf5948600'
+ '6827b29e2afc023089c4d46c6dde3fccf3ad01554ba6c22c20e7bce7a109224f')
diff --git a/mindustry-foos-client-bin.desktop b/mindustry-foos-client-bin.desktop
new file mode 100644
index 000000000000..f249947bb899
--- /dev/null
+++ b/mindustry-foos-client-bin.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=761
+Type=Application
+Name=Foo's Client
+Comment=Client modification of Mindustry
+Exec=mindustry-foos-client
+Icon=mindustry-foos-client
+Categories=Game;
+Terminal=false
diff --git a/mindustry-foos-client-bin.sh b/mindustry-foos-client-bin.sh
new file mode 100755
index 000000000000..0407d194390f
--- /dev/null
+++ b/mindustry-foos-client-bin.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/java -jar /usr/share/java/mindustry-foos-client/Mindustry.jar "$@"