aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2019-09-25 09:55:27 +0200
committerGordian Edenhofer2019-09-25 10:00:14 +0200
commit51d602408a3e31f9ac4c8459a389eb419ba45825 (patch)
tree1cbb1e51561c4fffe24f0b545e0318dbe32b0224
parent9a1fa5eaccf98b00c054313ed2ae42e0316aa09a (diff)
downloadaur-51d602408a3e31f9ac4c8459a389eb419ba45825.tar.gz
upgpkg: minecraft-server 1.14.4-2
Fix a bug which was most likely introduced in ada9f5931d preventing the `is_player_online` function to parse the response properly for some servers and in particular papermc. The bug deleted lines which were not intended to be deleted. As a fix, just stop deleting any lines as all subsequent invocations use grep anyway and hence already select the right line. upgpkg: cuberite 1.12b1049-1 upgpkg: papermc 1.14.4+b196-1 upgpkg: spigot 1.14.4+b103-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xminecraftd.sh6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 939cf7cd5519..e5da6fc06255 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = minecraft-server
pkgdesc = Minecraft server unit files, script, and jar
pkgver = 1.14.4
- pkgrel = 1
+ pkgrel = 2
url = https://minecraft.net/
install = minecraft-server.install
arch = any
@@ -29,6 +29,6 @@ pkgbase = minecraft-server
sha512sums = 19ee3646bfbace353b65c0373594edb654de11c9671f29cebad3b31109f29f94ade1d529d9f409b0989c376bef9b451585b22a1e0ac4295fcc92d9565f808418
sha512sums = 5203f6331f740ecfcea2a2cc653603ae97419baa89e08512f9d8feb63e4a52978442a69b313eccd9037b676a62ab528e2b533c0fb95a9c7177318279fe0cde79
sha512sums = 73132ec613e05c8ed7ebe4eda2395f1ea0733ffe94ba7e203e06246d5852139bbfb7a9073b2b01891282339a2f85676699cd889cde79d6317066e27fd65b1d67
- sha512sums = 9e806e35c207c96714f53a360e2d493f665867126398c2f12486b6f9d2b2db98c883e19aade703e18c31696e05808847762e494f743db7802127f415a00ba3bc
+ sha512sums = 55b4d5716aa82700c47a649299e908972b302baf75907e0d2051203c910a49dd0a29a498ce6baa43cc8317705bbfaa1eafac5f38f343acdd9d3090546e039231
pkgname = minecraft-server
diff --git a/PKGBUILD b/PKGBUILD
index 73716677dd80..101b78c8c251 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=minecraft-server
pkgver=1.14.4
_nonce=3dc3d84a581f14691199cf6831b71ed1296a9fdf
-pkgrel=1
+pkgrel=2
pkgdesc="Minecraft server unit files, script, and jar"
arch=('any')
url="https://minecraft.net/"
@@ -29,7 +29,7 @@ sha512sums=('b3d2852c6fa1b996bbf2fa9fc1fb860c6bca5136bcc5ddd3d236d85789c6bce8162
'19ee3646bfbace353b65c0373594edb654de11c9671f29cebad3b31109f29f94ade1d529d9f409b0989c376bef9b451585b22a1e0ac4295fcc92d9565f808418'
'5203f6331f740ecfcea2a2cc653603ae97419baa89e08512f9d8feb63e4a52978442a69b313eccd9037b676a62ab528e2b533c0fb95a9c7177318279fe0cde79'
'73132ec613e05c8ed7ebe4eda2395f1ea0733ffe94ba7e203e06246d5852139bbfb7a9073b2b01891282339a2f85676699cd889cde79d6317066e27fd65b1d67'
- '9e806e35c207c96714f53a360e2d493f665867126398c2f12486b6f9d2b2db98c883e19aade703e18c31696e05808847762e494f743db7802127f415a00ba3bc')
+ '55b4d5716aa82700c47a649299e908972b302baf75907e0d2051203c910a49dd0a29a498ce6baa43cc8317705bbfaa1eafac5f38f343acdd9d3090546e039231')
_game="minecraft"
_server_root="/srv/minecraft"
diff --git a/minecraftd.sh b/minecraftd.sh
index 0dca66f0a5a5..7b413a33b0a0 100755
--- a/minecraftd.sh
+++ b/minecraftd.sh
@@ -83,10 +83,10 @@ game_command() {
is_player_online() {
response="$(sleep_time=0.6 return_stdout=true game_command list)"
# Delete leading line and free response string from fancy characters
- response="$(echo "${response}" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g')"
+ response="$(echo "${response}" | sed -r -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g')"
# The list command prints a line containing the usernames after the last occurrence of ": "
# and since playernames may not contain this string the clean player-list can easily be retrieved.
- # Otherwiese check the first digit after the last occurrence of "There are". If it is 0 then there
+ # Otherwise check the first digit after the last occurrence of "There are". If it is 0 then there
# are no players on the server. Should this test fail as well. Assume that a player is online.
if [[ $(echo "${response}" | grep ":" | sed -e 's/.*\: //' | tr -d '\n' | wc -c) -le 1 ]]; then
# No player is online
@@ -473,7 +473,7 @@ case "${1:-}" in
;;
idle_server_daemon)
- # This shell be a hidden function which should only be invoced internally
+ # This shall be a hidden function which should only be invoced internally
idle_server_daemon
;;