aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-08-09 11:56:49 +0200
committerGordian Edenhofer2016-08-09 11:56:49 +0200
commit6d5dd87fc222126e62fef79e70621fbbe2b22c3b (patch)
tree263b7c8b5ddb65055902ddbf63acd152a45da96b
parent82a539adb82bd23eedc04766d617ce62a7433825 (diff)
downloadaur-6d5dd87fc222126e62fef79e70621fbbe2b22c3b.tar.gz
upgpkg: minecraft-server 1.10.2-3
Treat IDLE_SERVER varible case insensitive when comparing to "true". upgpkg: cuberite 1.9.4-5 upgpkg: spigot 1.10.2-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xminecraftd.sh6
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9138582a1f4c..d80a352c5ae9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,6 +29,6 @@ pkgbase = minecraft-server
md5sums = fef6fadd0739ae03ff71ba61025be207
md5sums = afb84ad0316af0aca421b36eaa2bbd90
md5sums = 025712e71efa4e21f625bddff28a2f15
- md5sums = 1d7efd1c778c7866dcfe9628df847e58
+ md5sums = 3cba3f02ad59b7d0df3df561409d7d1a
pkgname = minecraft-server
diff --git a/PKGBUILD b/PKGBUILD
index 589695ae63e9..ae738eb05ade 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ md5sums=('41c4e081defd80b09cb0391c894c2f3c'
'fef6fadd0739ae03ff71ba61025be207'
'afb84ad0316af0aca421b36eaa2bbd90'
'025712e71efa4e21f625bddff28a2f15'
- '1d7efd1c778c7866dcfe9628df847e58')
+ '3cba3f02ad59b7d0df3df561409d7d1a')
_game="minecraft"
_server_root="/srv/minecraft"
diff --git a/minecraftd.sh b/minecraftd.sh
index 440da2c2f906..a9cdeb5c555a 100755
--- a/minecraftd.sh
+++ b/minecraftd.sh
@@ -167,7 +167,7 @@ server_start() {
echo -e "\e[39;1m done\e[0m"
fi
- if [[ "${IDLE_SERVER}" == "true" ]]; then
+ if [[ "${IDLE_SERVER,,}" == "true" ]]; then
# Check for the availability of the netcat (nc) binaries
if [[ -z "${NETCAT_CMD}" ]]; then
>&2 echo "The netcat binaries are needed for suspending an idle server."
@@ -196,7 +196,7 @@ server_start() {
# Stop the server gracefully by saving everything prior and warning the users
server_stop() {
# Quit the idle daemon
- if [[ "${IDLE_SERVER}" == "true" ]]; then
+ if [[ "${IDLE_SERVER,,}" == "true" ]]; then
# Check for the availability of the netcat (nc) binaries
if [[ -z "${NETCAT_CMD}" ]]; then
>&2 echo "The netcat binaries are needed for suspending an idle server."
@@ -252,7 +252,7 @@ server_stop() {
# Print whether the server is running and if so give some information about memory usage and threads
server_status() {
# Print status information about the idle daemon
- if [[ "${IDLE_SERVER}" == "true" ]]; then
+ if [[ "${IDLE_SERVER,,}" == "true" ]]; then
# Check for the availability of the netcat (nc) binaries
if [[ -z "${NETCAT_CMD}" ]]; then
>&2 echo "The netcat binaries are needed for suspending an idle server."