aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWyRe2017-03-13 21:10:38 +0100
committerWyRe2017-03-13 21:10:38 +0100
commitff4c063255045cd9a80e22d48e1e36be5fb0688a (patch)
tree834d5f0db802c1333b832909b4336b145a66f4a5
downloadaur-ff4c063255045cd9a80e22d48e1e36be5fb0688a.tar.gz
Initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
-rw-r--r--minecrafter.install16
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..826861b4f972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = minecrafter
+ pkgdesc = Minecrafter fonts from http://www.dafont.com
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.dafont.com/es/minecrafter.font
+ install = minecrafter.install
+ arch = any
+ license = CCPL
+ depends = fontconfig
+ depends = xorg-font-utils
+ depends = unzip
+ noextract = minecrafter.zip
+ source = minecrafter.zip::http://dl.dafont.com/dl/?f=minecrafter
+ md5sums = 7b2874b4e67f6a018bba648031cfa6bc
+
+pkgname = minecrafter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3cd96698336
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Javier Fernández <WyRe12[at]gmail[dot]com>
+
+pkgname=minecrafter
+pkgver=1.0
+pkgrel=1
+pkgdesc="Minecrafter fonts from http://www.dafont.com"
+arch=(any)
+url="http://www.dafont.com/es/minecrafter.font"
+license=('CCPL')
+depends=('fontconfig' 'xorg-font-utils' 'unzip')
+source=("$pkgname.zip::http://dl.dafont.com/dl/?f=minecrafter")
+noextract=("$pkgname.zip")
+install=$pkgname.install
+md5sums=('7b2874b4e67f6a018bba648031cfa6bc')
+
+prepare() {
+ unzip -o -j -LL -qq $pkgname.zip -d $srcdir/$pkgname/
+}
+
+package() {
+ chmod 644 "$srcdir/$pkgname/"*.ttf
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+ cp -dpr --no-preserve=ownership "$srcdir/$pkgname/"*.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
diff --git a/minecrafter.install b/minecrafter.install
new file mode 100644
index 000000000000..2cef1d2fc330
--- /dev/null
+++ b/minecrafter.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/Type1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/Type1
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+