summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-26 18:58:11 +0800
committerzxp198210052024-02-26 18:58:11 +0800
commit351c12ffc6460d5d5cb723a3ffa15f16e250f10b (patch)
tree814183729dcde4230a47a67ec346c70dbb459e2a
parent6ae6f42a06992a55bd88e5da5fbcbaa45a2db089 (diff)
downloadaur-351c12ffc6460d5d5cb723a3ffa15f16e250f10b.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--minedigger.sh2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 706576c35129..ee9999bd3e3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = minedigger-bin
pkgdesc = Simple match-3 game prototype for Linux, Windows and Android
pkgver = 1.0
- pkgrel = 4
+ pkgrel = 5
url = https://play.google.com/store/apps/details?id=com.neodesys.minedigger
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
depends = sdl2
depends = sdl2_image
depends = sdl2_mixer
@@ -16,6 +16,6 @@ pkgbase = minedigger-bin
source = minedigger.sh
sha256sums = 8d88a7a1d9d4547789f9f828632aca4273e09ca72799c4c7238af3e850d3b1ae
sha256sums = e544a0f449e2e13fd4d5367d1ae4bcf9dd85c93cf9057189477bc282c4b5fff0
- sha256sums = a22f8c5d978468a4ed34e64ea23fa38493c7a51d9191a640037c2aa31b118af3
+ sha256sums = a9783526d93e6c72c7e1551cc5cc513fd6056dcc4593abe8fac815721d32dd5a
pkgname = minedigger-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2ae3eaca9ab6..ef52b079fd46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=minedigger-bin
_pkgname=MineDigger
pkgver=1.0
-pkgrel=4
+pkgrel=5
pkgdesc="Simple match-3 game prototype for Linux, Windows and Android"
arch=('x86_64')
url="https://play.google.com/store/apps/details?id=com.neodesys.minedigger"
_ghurl="https://github.com/neodesys/MineDigger"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -23,12 +23,12 @@ source=(
)
sha256sums=('8d88a7a1d9d4547789f9f828632aca4273e09ca72799c4c7238af3e850d3b1ae'
'e544a0f449e2e13fd4d5367d1ae4bcf9dd85c93cf9057189477bc282c4b5fff0'
- 'a22f8c5d978468a4ed34e64ea23fa38493c7a51d9191a640037c2aa31b118af3')
+ 'a9783526d93e6c72c7e1551cc5cc513fd6056dcc4593abe8fac815721d32dd5a')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|${_pkgname}|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -f -n -q --categories "Game" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
+ gendesk -f -n -q --categories="Game" --name ="${_pkgname}" --exec="${pkgname%-bin} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/minedigger.sh b/minedigger.sh
index 0b7a0975f2bd..8c3bc7d4fc8a 100644
--- a/minedigger.sh
+++ b/minedigger.sh
@@ -4,4 +4,4 @@ _APPDIR=/opt/@appname@
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
cd "${_APPDIR}"
-exec "${_RUNNAME}" "$@" | exit $? \ No newline at end of file
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file