summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilip Weiss2018-11-19 21:08:32 +0100
committerFilip Weiss2018-11-19 21:08:32 +0100
commit0fffc80f0e433d0e86ae948e6a4c0c5f8bca4e8f (patch)
tree1e6a00fc8b1f05bd6526413b9ce6e21b6a7f4675
parent89afddc90293de54e05399847b8ce594a46a55f5 (diff)
downloadaur-0fffc80f0e433d0e86ae948e6a4c0c5f8bca4e8f.tar.gz
release 0.0.1
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51ecf8c9daa6..b1b3b7e553d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = minepkg
pkgdesc = Installs and manages Minecraft mods with ease
pkgver = 0.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fiws/minepkg
arch = x86_64
license = MIT
makedepends = go
optdepends = docker
- source = https://github.com/fiws/minepkg/archive/v0.0.1-beta.tar.gz
+ source = https://github.com/fiws/minepkg/archive/v0.0.1.tar.gz
sha1sums = 67c59d7f04555b22a08e0bf611a91822ea817c9b
pkgname = minepkg
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c32b546f7db3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 3731fd099896..816eaef01055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=minepkg
pkgver=0.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Installs and manages Minecraft mods with ease"
arch=('x86_64')
url="https://github.com/fiws/minepkg"
@@ -11,15 +11,15 @@ groups=()
depends=()
makedepends=('go')
optdepends=('docker')
-source=("https://github.com/fiws/$pkgname/archive/v$pkgver-beta.tar.gz")
-sha1sums=('67c59d7f04555b22a08e0bf611a91822ea817c9b')
+source=("https://github.com/fiws/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('9ca225e0baf0fb6d755436d27fc9a18deadbb560167a1c121dff3cbacb2b95d2')
build() {
- cd "$srcdir/$pkgname-$pkgver-beta"
+ cd "$srcdir/$pkgname-$pkgver"
go build -ldflags="-s -w" -o ./out/minepkg main.go
}
package() {
- cd "$srcdir/$pkgname-$pkgver-beta"
+ cd "$srcdir/$pkgname-$pkgver"
install -Dm755 "out/minepkg" "$pkgdir/usr/bin/minepkg"
-}
+} \ No newline at end of file