summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaroldLoui2023-01-24 12:56:50 +0800
committerHaroldLoui2023-01-24 12:56:50 +0800
commit989381aacc41aea43f6d4f38942213f98c2db40b (patch)
tree1c8bfa61fe2bb319c4cc20737e949437f94f2043
downloadaur-989381aacc41aea43f6d4f38942213f98c2db40b.tar.gz
first commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD51
-rw-r--r--minesweeper-tauri.desktop10
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b4b4936af9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = minesweeper-tauri-git
+ pkgdesc = A minesweeper game follow windowsXP style based on tauri.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/HaroldLoui/minesweeper-tauri
+ arch = x86_64
+ arch = aarch64
+ license = custom
+ makedepends = cargo-tauri
+ makedepends = jq
+ makedepends = rust
+ makedepends = moreutils
+ depends = git
+ depends = webkit2gtk
+ depends = libappindicator-gtk3
+ optdepends = appmenu-gtk-module: Application Menu GTK+ Module
+ source = minesweeper-tauri-0.1.0-git::git+https://github.com/HaroldLoui/minesweeper-tauri
+ source = minesweeper-tauri.desktop
+ sha256sums = SKIP
+ sha256sums = 5608145f8050f7794bfd32c9016d2d2f6e0c39cf90e2f244feead154ceca3e60
+
+pkgname = minesweeper-tauri-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cdac608ebc45
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*-git/
+*.pkg.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c948476cea39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: HaroldLoui<Riven970309@gmail.com>
+pkgname=minesweeper-tauri-git
+base=minesweeper-tauri
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A minesweeper game follow windowsXP style based on tauri."
+arch=('x86_64' 'aarch64')
+url="https://github.com/HaroldLoui/minesweeper-tauri"
+license=('custom')
+depends=('git' 'webkit2gtk' 'libappindicator-gtk3')
+makedepends=('cargo-tauri' 'jq' 'rust' 'moreutils')
+optdepends=('appmenu-gtk-module: Application Menu GTK+ Module')
+source=(
+ "${base}-${pkgver}-git::git+${url}"
+ "${base}.desktop"
+)
+
+sha256sums=(
+ 'SKIP'
+ '5608145f8050f7794bfd32c9016d2d2f6e0c39cf90e2f244feead154ceca3e60'
+)
+
+prepare(){
+ cd $srcdir/${base}-${pkgver}-git
+
+ cd src-tauri
+ # only build the excutable
+ jq '.tauri.bundle.active = false' tauri.conf.json|sponge tauri.conf.json
+ # disable updater
+ jq '.tauri.updater.active = false' tauri.conf.json|sponge tauri.conf.json
+}
+
+build(){
+ cd $srcdir/${base}-${pkgver}-git
+ cargo-tauri build
+}
+
+package(){
+ cd $srcdir/${base}-${pkgver}-git
+ install -Dm755 src-tauri/target/release/minesweeper -t ${pkgdir}/usr/bin/
+ mv ${pkgdir}/usr/bin/minesweeper ${pkgdir}/usr/bin/minesweeper-tauri
+
+ # Icons
+ install -Dm644 src-tauri/icons/icon.png ${pkgdir}/usr/share/icons/${base}.png
+ for i in 32x32 128x128; do
+ install -Dm644 src-tauri/icons/${i}.png \
+ "$pkgdir"/usr/share/icons/hicolor/$i/apps/${base}.png
+ done
+
+ install -Dm644 ${srcdir}/${base}.desktop -t ${pkgdir}/usr/share/applications
+} \ No newline at end of file
diff --git a/minesweeper-tauri.desktop b/minesweeper-tauri.desktop
new file mode 100644
index 000000000000..259d0face1a5
--- /dev/null
+++ b/minesweeper-tauri.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Categories=Game;
+Comment=A minesweeper game follow windowsXP style based on tauri.
+Comment[zh_CN]=一款基于tauri制作仿照winxp系统风格的扫雷游戏。
+Exec=minesweeper-tauri
+Icon=minesweeper-tauri
+Name=Minesweeper
+Name[zh_CN]=扫雷
+Terminal=false
+Type=Application