summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-12-25 21:21:15 +0100
committerROllerozxa2021-12-25 21:21:15 +0100
commit0e01ed28a71603e380e486cc3a0b6eb704794578 (patch)
tree0527dbd5fec1410e040723d4be45c73bf7e5d7d2
downloadaur-0e01ed28a71603e380e486cc3a0b6eb704794578.tar.gz
Initializing new package from master Git repository.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ace7695b1031
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = minetest-build-n-buy
+ pkgdesc = A game inspired by Minecraft Championship's Build Mart, where you have to replicate mini build and to get the materials for them, you have to go 'shopping'.
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://content.minetest.net/packages/j45/build_n_buy/
+ arch = any
+ license = MIT
+ depends = minetest-common
+ noextract = build_n_buy-1.1.zip
+ options = !strip
+ source = build_n_buy-1.1.zip::https://content.minetest.net/packages/j45/build_n_buy/releases/10196/download/
+ sha256sums = 6cd5adb31d4d07ba921759dfd0c302f2103c7d0185dccb8d8d020e45369c900d
+
+pkgname = minetest-build-n-buy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4055ef0da4b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25d150c3efd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
+pkgname=minetest-build-n-buy
+_pkgname=build_n_buy
+_pkgauthor=j45
+pkgver=1.1
+_cdbrel=10196
+pkgrel=1
+pkgdesc="A game inspired by Minecraft Championship's Build Mart, where you have to replicate mini build and to get the materials for them, you have to go 'shopping'."
+license=("MIT")
+sha256sums=('6cd5adb31d4d07ba921759dfd0c302f2103c7d0185dccb8d8d020e45369c900d')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
+options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
+
+package() {
+ install -d "${pkgdir}/usr/share/minetest/games/"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/"
+}