summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-07-28 14:39:47 +0200
committerROllerozxa2021-07-28 14:39:47 +0200
commit391fc22a25aa40e8273755f47c9ba2f0fd14ca23 (patch)
tree2068b5db5a49b19b4a16af3e3c2e730d2969813f
parent79ef59dd9e9fd031b14c6567358ac8c67b4aa928 (diff)
downloadaur-391fc22a25aa40e8273755f47c9ba2f0fd14ca23.tar.gz
Update to fix compatibility with upstream.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 4 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31f1158caf28..0da149f1c0c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = minetest-git-leveldb
pkgdesc = Voxel-based sandbox game engine (Git version with LevelDB support)
- pkgver = 5.4.0.r262.gbf3acbf38
+ pkgver = 5.4.0.r267.g2866918f3
pkgrel = 1
url = https://www.minetest.net/
install = install
diff --git a/PKGBUILD b/PKGBUILD
index 62dcac1e84f5..a07ec167b7ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Konsta Kokkinen <kray@tsundere.fi>
pkgname=minetest-git-leveldb
_pkgname=minetest
-pkgver=5.4.0.r262.gbf3acbf38
+pkgver=5.4.0.r267.g2866918f3
pkgrel=1
pkgdesc='Voxel-based sandbox game engine (Git version with LevelDB support)'
url='https://www.minetest.net/'
@@ -26,10 +26,7 @@ pkgver() {
}
build() {
- cd "${srcdir}/irrlicht"
- cmake -G Ninja . \
- -DBUILD_SHARED_LIBS=0
- ninja
+ ln -s "${srcdir}/irrlicht/" "${srcdir}/${_pkgname}/lib/irrlichtmt"
cd "${srcdir}/${_pkgname}"
cmake -G Ninja . \
@@ -37,9 +34,7 @@ build() {
-DENABLE_LEVELDB=1 \
-DENABLE_POSTGRESQL=0 \
-DENABLE_SPATIAL=1 \
- -DENABLE_REDIS=1 \
- -DIRRLICHT_INCLUDE_DIR="${srcdir}/irrlicht/include/" \
- -DIRRLICHT_LIBRARY="${srcdir}/irrlicht/lib/Linux/libIrrlichtMt.a"
+ -DENABLE_REDIS=1
ninja
}