summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-12-25 21:21:31 +0100
committerROllerozxa2021-12-25 21:21:31 +0100
commit45f690179100a10cf9c065c771d7e4653d3428c2 (patch)
tree2c2a584cbd4be51adb1c8aff186791edd64b9545
downloadaur-45f690179100a10cf9c065c771d7e4653d3428c2.tar.gz
Initializing new package from master Git repository.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4972e6264cbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = minetest-grand-theft-box
+ pkgdesc = Grand Theft Box!
+ pkgver = 10176
+ pkgrel = 1
+ url = https://content.minetest.net/packages/jamiebearcub/grand_theft_box/
+ arch = any
+ license = LGPLv2.1
+ depends = minetest-common
+ noextract = grand_theft_box-10176.zip
+ options = !strip
+ source = grand_theft_box-10176.zip::https://content.minetest.net/packages/jamiebearcub/grand_theft_box/releases/10176/download/
+ sha256sums = 3725ec840215b7955e4652c28fe497d54c31ab66d51fc5cd4340f77bb158d526
+
+pkgname = minetest-grand-theft-box
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4055ef0da4b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0373b0105c65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
+pkgname=minetest-grand-theft-box
+_pkgname=grand_theft_box
+_pkgauthor=jamiebearcub
+pkgver=10176
+_cdbrel=10176
+pkgrel=1
+pkgdesc="Grand Theft Box!"
+license=("LGPLv2.1")
+sha256sums=('3725ec840215b7955e4652c28fe497d54c31ab66d51fc5cd4340f77bb158d526')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
+options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
+
+package() {
+ install -d "${pkgdir}/usr/share/minetest/games/"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/"
+}