summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshellkr2018-10-13 00:28:41 +0200
committershellkr2018-10-13 00:28:41 +0200
commit23aeda0f255114b80a961e8ad81d0b921464f251 (patch)
treec5c2aa86fe75e6b5560c2036abb8eed2830ff94b
downloadaur-23aeda0f255114b80a961e8ad81d0b921464f251.tar.gz
initial push
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--minetest-mod-bike-git.install22
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f48862c08d62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Oct 12 22:28:41 UTC 2018
+pkgbase = minetest-mod-bike-git
+ pkgdesc = Bike mod for Minetest. (Mod for Minetest)
+ pkgver = 32.3e9a039
+ pkgrel = 1
+ url = https://gitlab.com/h2mm/bike
+ install = minetest-mod-bike-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ optdepends = minetest-usrdir_patch
+ provides = minetest-mod-bike
+ source = minetest-mod-bike::git+https://gitlab.com/h2mm/bike.git
+ md5sums = SKIP
+
+pkgname = minetest-mod-bike-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..380c03d716e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: shellkr <revoltism+AUR$gmail.com>
+
+pkgname=minetest-mod-bike-git
+_gitname=${pkgname%-git*}
+pkgver=32.3e9a039
+pkgrel=1
+pkgdesc='Bike mod for Minetest. (Mod for Minetest)'
+arch=('any')
+url="https://gitlab.com/h2mm/bike"
+license=('custom')
+depends=()
+optdepends=('minetest-usrdir_patch')
+makedepends=('git')
+provides=("$_gitname")
+install=$pkgname.install
+source=("$_gitname::git+https://gitlab.com/h2mm/bike.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+ cp -r * "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+}
+
diff --git a/minetest-mod-bike-git.install b/minetest-mod-bike-git.install
new file mode 100644
index 000000000000..801a1209b181
--- /dev/null
+++ b/minetest-mod-bike-git.install
@@ -0,0 +1,22 @@
+
+post_install() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' Mod will be installed to /usr/share/minetest/mods which is the default'
+ echo ' directory for mods. This is disabled by default though and needs a patch.'
+ echo ' You can install "minetest-usrdir_patch" which handles this for you.'
+ echo
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' Mod will be installed to /usr/share/minetest/mods which is the default'
+ echo ' directory for mods. This is disabled by default though and needs a patch.'
+ echo ' You can install "minetest-usrdir_patch" which handles this for you.'
+ echo
+ echo
+}