summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshellkr2016-01-21 03:14:31 +0100
committershellkr2016-01-21 03:14:31 +0100
commit2ef19c06d684577528bb713cd5d8b274d9713f32 (patch)
tree29b34404b69db7c25a7ebecfdeeeb8194bd8e183
downloadaur-2ef19c06d684577528bb713cd5d8b274d9713f32.tar.gz
initial push
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--minetest-mod-jumping-git.install26
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9683da87c582
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 02:08:25 UTC 2016
+pkgbase = minetest-mod-jumping-git
+ pkgdesc = Minetest mod that adds jumping stuff like trampolines and cushions
+ pkgver = 7.47df671
+ pkgrel = 1
+ url = https://github.com/Jeija/minetest-mod-jumping
+ install = minetest-mod-jumping-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ depends = minetest
+ provides = minetest-mod-jumping
+ source = minetest-mod-jumping::git://github.com/Jeija/minetest-mod-jumping.git
+ md5sums = SKIP
+
+pkgname = minetest-mod-jumping-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4127a8b9750a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: shellkr <revoltism+AUR$gmail.com>
+
+_gitname=minetest-mod-jumping
+pkgname=minetest-mod-jumping-git
+pkgver=7.47df671
+pkgrel=1
+pkgdesc="Minetest mod that adds jumping stuff like trampolines and cushions"
+arch=('any')
+url="https://github.com/Jeija/minetest-mod-jumping"
+license=('custom')
+depends=('minetest')
+makedepends=('git')
+provides=('minetest-mod-jumping')
+install=('minetest-mod-jumping-git.install')
+source=("$_gitname::git://github.com/Jeija/minetest-mod-jumping.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/$_gitname"
+ cp -r * "$pkgdir/usr/share/minetest/mods/$_gitname"
+}
+
diff --git a/minetest-mod-jumping-git.install b/minetest-mod-jumping-git.install
new file mode 100644
index 000000000000..475c7142a46d
--- /dev/null
+++ b/minetest-mod-jumping-git.install
@@ -0,0 +1,26 @@
+
+post_install() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
+ echo ' recognize the default install dir'
+ echo
+ echo ' sudo mv /usr/share/minetest/mods/minetest-mod-jumping ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/minetest-mod-jumping'
+ echo
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
+ echo ' recognize the default install dir'
+ echo
+ echo ' sudo mv /usr/share/minetest/mods/minetest-mod-jumping ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/minetest-mod-jumping'
+ echo
+ echo
+}