summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshellkr2016-01-22 03:50:21 +0100
committershellkr2016-01-22 03:50:21 +0100
commitd3d7f4e4baba5ed890e59c84d1d1dd355aee084a (patch)
tree3a8a07ce905dcee89dc55ffa45a14ed0cea313a1
parent2ef19c06d684577528bb713cd5d8b274d9713f32 (diff)
downloadaur-d3d7f4e4baba5ed890e59c84d1d1dd355aee084a.tar.gz
corrected the naming after minetest recommendations
-rw-r--r--PKGBUILD10
-rw-r--r--minetest-mod-jumping-git.install8
2 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4127a8b9750a..08c4645406f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: shellkr <revoltism+AUR$gmail.com>
-_gitname=minetest-mod-jumping
pkgname=minetest-mod-jumping-git
+_gitname=${pkgname%-git*}
pkgver=7.47df671
pkgrel=1
pkgdesc="Minetest mod that adds jumping stuff like trampolines and cushions"
@@ -10,8 +10,8 @@ url="https://github.com/Jeija/minetest-mod-jumping"
license=('custom')
depends=('minetest')
makedepends=('git')
-provides=('minetest-mod-jumping')
-install=('minetest-mod-jumping-git.install')
+provides=$_gitname
+install=$pkgname.install
source=("$_gitname::git://github.com/Jeija/minetest-mod-jumping.git")
md5sums=('SKIP')
@@ -22,7 +22,7 @@ pkgver() {
package() {
cd "$srcdir/$_gitname"
- mkdir -p "$pkgdir/usr/share/minetest/mods/$_gitname"
- cp -r * "$pkgdir/usr/share/minetest/mods/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+ cp -r * "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
}
diff --git a/minetest-mod-jumping-git.install b/minetest-mod-jumping-git.install
index 475c7142a46d..1e176219028b 100644
--- a/minetest-mod-jumping-git.install
+++ b/minetest-mod-jumping-git.install
@@ -6,8 +6,8 @@ post_install() {
echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
echo ' recognize the default install dir'
echo
- echo ' sudo mv /usr/share/minetest/mods/minetest-mod-jumping ~/.minetest/mods'
- echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/minetest-mod-jumping'
+ echo ' sudo mv /usr/share/minetest/mods/jumping ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/jumping'
echo
echo
}
@@ -19,8 +19,8 @@ post_upgrade() {
echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
echo ' recognize the default install dir'
echo
- echo ' sudo mv /usr/share/minetest/mods/minetest-mod-jumping ~/.minetest/mods'
- echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/minetest-mod-jumping'
+ echo ' sudo mv /usr/share/minetest/mods/jumping ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/jumping'
echo
echo
}