summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshellkr2016-01-26 16:38:21 +0100
committershellkr2016-01-26 16:38:21 +0100
commit499e5fb7ee27c80ab55cdf6f45e29827838b59f1 (patch)
tree7887179c226afe673a97aea4228e09c4c6949104
downloadaur-499e5fb7ee27c80ab55cdf6f45e29827838b59f1.tar.gz
initial push
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--minetest-mod-throwing_enhanced-git.install26
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c643bf6aa489
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 15:38:04 UTC 2016
+pkgbase = minetest-mod-throwing_enhanced-git
+ pkgdesc = Updated and enhanced throwing mod for Minetest (adds many bows and arrows).
+ pkgver = 48.61567b3
+ pkgrel = 1
+ url = https://gitlab.com/echoes91/throwing
+ install = minetest-mod-throwing_enhanced-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ depends = minetest
+ provides = minetest-mod-throwing
+ source = minetest-mod-throwing::git+https://gitlab.com/echoes91/throwing.git
+ md5sums = SKIP
+
+pkgname = minetest-mod-throwing_enhanced-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fd2506872ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: shellkr <revoltism+AUR$gmail.com>
+
+pkgname=minetest-mod-throwing_enhanced-git
+_gitname=${pkgname%_enh*}
+pkgver=48.61567b3
+pkgrel=1
+pkgdesc='Updated and enhanced throwing mod for Minetest (adds many bows and arrows).'
+arch=('any')
+url="https://gitlab.com/echoes91/throwing"
+license=('custom')
+depends=('minetest')
+makedepends=('git')
+provides=$_gitname
+install=$pkgname.install
+source=("$_gitname::git+https://gitlab.com/echoes91/throwing.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+ cp -r * "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+}
+
diff --git a/minetest-mod-throwing_enhanced-git.install b/minetest-mod-throwing_enhanced-git.install
new file mode 100644
index 000000000000..5865247cc49e
--- /dev/null
+++ b/minetest-mod-throwing_enhanced-git.install
@@ -0,0 +1,26 @@
+
+post_install() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
+ echo ' recognize the default install dir'
+ echo
+ echo ' sudo mv /usr/share/minetest/mods/throwing_enhanced ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/throwing_enhanced'
+ echo
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
+ echo ' recognize the default install dir'
+ echo
+ echo ' sudo mv /usr/share/minetest/mods/throwing_enhanced ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/throwing_enhanced'
+ echo
+ echo
+}