summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshellkr2016-02-20 20:14:03 +0100
committershellkr2016-02-20 20:14:03 +0100
commit0d4cdd88cbeaae2a5927cde989a0f63701757b63 (patch)
tree01827824acf3680500d19b1f3cbeb77f35027afc
downloadaur-0d4cdd88cbeaae2a5927cde989a0f63701757b63.tar.gz
initial push
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--minetest-mod-travelnet-git.install26
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13d625199a09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Feb 20 19:13:25 UTC 2016
+pkgbase = minetest-mod-travelnet-git
+ pkgdesc = Network of teleporter-boxes that allow easy travelling to other boxes on the same network (Mod for Minetest)
+ pkgver = 41.4779487
+ pkgrel = 1
+ url = https://github.com/Sokomine/travelnet
+ install = minetest-mod-travelnet-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ depends = minetest
+ provides = minetest-mod-travelnet
+ source = minetest-mod-travelnet::git+https://github.com/Sokomine/travelnet.git
+ md5sums = SKIP
+
+pkgname = minetest-mod-travelnet-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d65ef4d7198e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: shellkr <revoltism+AUR$gmail.com>
+
+pkgname=minetest-mod-travelnet-git
+_gitname=${pkgname%-git*}
+pkgver=41.4779487
+pkgrel=1
+pkgdesc='Network of teleporter-boxes that allow easy travelling to other boxes on the same network (Mod for Minetest)'
+arch=('any')
+url="https://github.com/Sokomine/travelnet"
+license=('custom')
+depends=('minetest')
+makedepends=('git')
+provides=("$_gitname")
+install=$pkgname.install
+source=("$_gitname::git+https://github.com/Sokomine/travelnet.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+ cp -r * "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+}
+
diff --git a/minetest-mod-travelnet-git.install b/minetest-mod-travelnet-git.install
new file mode 100644
index 000000000000..45b2babd48b5
--- /dev/null
+++ b/minetest-mod-travelnet-git.install
@@ -0,0 +1,26 @@
+
+post_install() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
+ echo ' recognize the default install dir'
+ echo
+ echo ' sudo mv /usr/share/minetest/mods/travelnet ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/travelnet'
+ echo
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
+ echo ' recognize the default install dir'
+ echo
+ echo ' sudo mv /usr/share/minetest/mods/travelnet ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/travelnet'
+ echo
+ echo
+}