summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-12-25 21:22:08 +0100
committerROllerozxa2021-12-25 21:22:08 +0100
commit9994165fe7b72558b42c8a218cef82eabb73223f (patch)
treebb0d8b6245cee0c7dfe986c8e6602355becb89f2
downloadaur-9994165fe7b72558b42c8a218cef82eabb73223f.tar.gz
Initializing new package from master Git repository.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d610e1913512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = minetest-modular-portals
+ pkgdesc = Explore a strange hall filled with portals
+ pkgver = 10101
+ pkgrel = 1
+ url = https://content.minetest.net/packages/UnbrokenUnworn/modular_portals/
+ arch = any
+ license = AGPLv3
+ depends = minetest-common
+ noextract = modular_portals-10101.zip
+ options = !strip
+ source = modular_portals-10101.zip::https://content.minetest.net/packages/UnbrokenUnworn/modular_portals/releases/10101/download/
+ sha256sums = 8f76e2f76b93d43615080ab5b763aeff698f8ebf71eb578982eef162d999a80d
+
+pkgname = minetest-modular-portals
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4055ef0da4b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..795893cd46d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
+pkgname=minetest-modular-portals
+_pkgname=modular_portals
+_pkgauthor=UnbrokenUnworn
+pkgver=10101
+_cdbrel=10101
+pkgrel=1
+pkgdesc="Explore a strange hall filled with portals"
+license=("AGPLv3")
+sha256sums=('8f76e2f76b93d43615080ab5b763aeff698f8ebf71eb578982eef162d999a80d')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
+options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
+
+package() {
+ install -d "${pkgdir}/usr/share/minetest/games/"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/"
+}