summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-11-02 17:30:10 +0100
committerROllerozxa2021-11-02 17:30:10 +0100
commit159172332e0bbdf693f53fca7e4f4394d0f2237c (patch)
tree5d5f62dcd2e7a024e6860bd5ed62ec332cfa48b8
downloadaur-159172332e0bbdf693f53fca7e4f4394d0f2237c.tar.gz
Initializing new package from master Git repository.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20a21c641986
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = minetest-nomansland
+ pkgdesc = Survive No Man's Land, where TNT rains from the sky, and destroys everything.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://content.minetest.net/packages/Big_Caballito/no_mans_land/
+ arch = any
+ license = GPLv3
+ depends = minetest-common
+ noextract = no_mans_land-0.1.1.zip
+ options = !strip
+ source = no_mans_land-0.1.1.zip::https://content.minetest.net/packages/Big_Caballito/no_mans_land/releases/8685/download/
+ sha256sums = 7e6e4acddce66b09599e512355e8991975bdc817a8b8206cd0d2e56c105b02c4
+
+pkgname = minetest-nomansland
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09e733d7e2b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
+pkgname=minetest-nomansland
+_pkgname=no_mans_land
+_pkgauthor=Big_Caballito
+pkgver=0.1.1
+_cdbrel=8685
+pkgrel=1
+pkgdesc="Survive No Man's Land, where TNT rains from the sky, and destroys everything."
+license=("GPLv3")
+sha256sums=('7e6e4acddce66b09599e512355e8991975bdc817a8b8206cd0d2e56c105b02c4')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
+options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
+
+package() {
+ install -d "${pkgdir}/usr/share/minetest/games/"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/"
+}