summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-12-25 21:22:40 +0100
committerROllerozxa2021-12-25 21:22:40 +0100
commit44fd67ce23ff57480c4256616fc5f7a104858203 (patch)
tree29d6b79570409238bc1a8440f6362eea7e0477fe
downloadaur-44fd67ce23ff57480c4256616fc5f7a104858203.tar.gz
Initializing new package from master Git repository.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d046e0d6083
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = minetest-stella
+ pkgdesc = You start on a small island and your goal is to enlarge it.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://content.minetest.net/packages/1248/stella/
+ arch = any
+ license = LGPLv2.1
+ depends = minetest-common
+ noextract = stella-1.0.0.zip
+ options = !strip
+ source = stella-1.0.0.zip::https://content.minetest.net/packages/1248/stella/releases/10125/download/
+ sha256sums = ca1aaa618e4f3572c602e4ff3043324c20061894117b20bdcc6d77288c7c9b3a
+
+pkgname = minetest-stella
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4055ef0da4b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76f1f60ed4de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
+pkgname=minetest-stella
+_pkgname=stella
+_pkgauthor=1248
+pkgver=1.0.0
+_cdbrel=10125
+pkgrel=1
+pkgdesc="You start on a small island and your goal is to enlarge it."
+license=("LGPLv2.1")
+sha256sums=('ca1aaa618e4f3572c602e4ff3043324c20061894117b20bdcc6d77288c7c9b3a')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
+options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
+
+package() {
+ install -d "${pkgdir}/usr/share/minetest/games/"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/"
+}