summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-08-18 14:35:38 +0200
committerROllerozxa2021-08-18 14:35:38 +0200
commit2e2f853d5051bef4aa46d68b01860e088d11fc86 (patch)
tree088fdf5b49f525fa0e0667b9def7f8a00f302a24
parenteb28bbfbd23356b5f3a5978adc57bc7bb77eb8b8 (diff)
downloadaur-2e2f853d5051bef4aa46d68b01860e088d11fc86.tar.gz
Rework PKGBUILD, update to latest.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c473aeaa0b5..dd56b0c2ddd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,9 @@ pkgbase = minetest-whynot
arch = any
license = GPLv3
depends = minetest-common
+ noextract = whynot_game-2021.02.12.zip
options = !strip
- source = whynot-6511.zip::https://content.minetest.net/packages/bell07/whynot_game/releases/6511/download/
+ source = whynot_game-2021.02.12.zip::https://content.minetest.net/packages/bell07/whynot_game/releases/6511/download/
sha256sums = e7fcd73aeae0d7becc43869d0b5555c3981ec5f79847390dd3eb5727deb7634d
pkgname = minetest-whynot
-
diff --git a/PKGBUILD b/PKGBUILD
index 7e93c50e26a7..0e18528c6944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: ROllerozxa (temporaryemail4meh [gee mail])
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
pkgname=minetest-whynot
+_pkgname=whynot_game
+_pkgauthor=bell07
pkgver=2021.02.12
-_pkgver=6511
+_cdbrel=6511
pkgrel=1
-pkgdesc="Aims to get all existing high quality mods working together"
-arch=("any")
-url="https://content.minetest.net/packages/bell07/whynot_game/"
+pkgdesc="Aims to get all existing high quality mods working together "
license=("GPLv3")
-depends=("minetest-common")
-source=("whynot-$_pkgver.zip::https://content.minetest.net/packages/bell07/whynot_game/releases/${_pkgver}/download/")
sha256sums=('e7fcd73aeae0d7becc43869d0b5555c3981ec5f79847390dd3eb5727deb7634d')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
package() {
- cd whynot_game
- find . -type f | while read f; do
- install -Dm644 "$f" "${pkgdir}/usr/share/minetest/games/whynot/$f"
- done
+ install -d "${pkgdir}/usr/share/minetest/games/"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/"
}