summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-05-22 20:55:19 +0200
committerROllerozxa2021-05-22 20:55:19 +0200
commiteb28bbfbd23356b5f3a5978adc57bc7bb77eb8b8 (patch)
tree8b61e427b03009893f3050ac0dc75a0e32380664
downloadaur-eb28bbfbd23356b5f3a5978adc57bc7bb77eb8b8.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c473aeaa0b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = minetest-whynot
+ pkgdesc = Aims to get all existing high quality mods working together
+ pkgver = 2021.02.12
+ pkgrel = 1
+ url = https://content.minetest.net/packages/bell07/whynot_game/
+ arch = any
+ license = GPLv3
+ depends = minetest-common
+ options = !strip
+ source = whynot-6511.zip::https://content.minetest.net/packages/bell07/whynot_game/releases/6511/download/
+ sha256sums = e7fcd73aeae0d7becc43869d0b5555c3981ec5f79847390dd3eb5727deb7634d
+
+pkgname = minetest-whynot
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4055ef0da4b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e93c50e26a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: ROllerozxa (temporaryemail4meh [gee mail])
+pkgname=minetest-whynot
+pkgver=2021.02.12
+_pkgver=6511
+pkgrel=1
+pkgdesc="Aims to get all existing high quality mods working together"
+arch=("any")
+url="https://content.minetest.net/packages/bell07/whynot_game/"
+license=("GPLv3")
+depends=("minetest-common")
+source=("whynot-$_pkgver.zip::https://content.minetest.net/packages/bell07/whynot_game/releases/${_pkgver}/download/")
+sha256sums=('e7fcd73aeae0d7becc43869d0b5555c3981ec5f79847390dd3eb5727deb7634d')
+options=(!strip)
+
+package() {
+ cd whynot_game
+ find . -type f | while read f; do
+ install -Dm644 "$f" "${pkgdir}/usr/share/minetest/games/whynot/$f"
+ done
+}