summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorROllerozxa2021-08-18 16:13:45 +0200
committerROllerozxa2021-08-18 16:13:45 +0200
commit21cafcf12570daec589e277f49d804e197c4a13a (patch)
tree2c8fb0b10b93ad492ad3da6ddb60c3f5284a89fa
downloadaur-21cafcf12570daec589e277f49d804e197c4a13a.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b79c92f12c63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = minetest-xaenvironment
+ pkgdesc = A game that aims to contain lots of environments and things.
+ pkgver = 2021.04.02
+ pkgrel = 1
+ url = https://content.minetest.net/packages/AiTechEye/xaenvironment/
+ arch = any
+ license = LGPLv2.1
+ depends = minetest-common
+ noextract = xaenvironment-2021.04.02.zip
+ options = !strip
+ source = xaenvironment-2021.04.02.zip::https://content.minetest.net/packages/AiTechEye/xaenvironment/releases/7314/download/
+ sha256sums = 0c1b19016e43e65f73513b4912eca301fa2aca343d662909e6e9ef9188eaa6e8
+
+pkgname = minetest-xaenvironment
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d4055ef0da4b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfc6cacd75b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
+pkgname=minetest-xaenvironment
+_pkgname=xaenvironment
+_pkgauthor=AiTechEye
+pkgver=2021.04.02
+_cdbrel=7314
+pkgrel=1
+pkgdesc="A game that aims to contain lots of environments and things."
+license=("LGPLv2.1")
+sha256sums=('0c1b19016e43e65f73513b4912eca301fa2aca343d662909e6e9ef9188eaa6e8')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
+options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
+
+package() {
+ install -d "${pkgdir}/usr/share/minetest/games/"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/"
+}