summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2015-04-11 04:37:34 +0800
committerTing-Wei Lan2015-04-11 04:37:34 +0800
commit7157da3e66ceb6109fb1e88bfd48eda69b99568b (patch)
tree9583fc893416f78bb27adc7e1bed10b77e203640
downloadaur-7157da3e66ceb6109fb1e88bfd48eda69b99568b.tar.gz
mingw-w64-adwaita-icon-theme: 3.16.0 (initial commit)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dde0c15688d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-adwaita-icon-theme
+ pkgdesc = Adwaita icon theme (mingw-w64)
+ pkgver = 3.16.0
+ pkgrel = 1
+ url = http://www.gnome.org
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-configure
+ makedepends = intltool
+ depends = mingw-w64-hicolor-icon-theme
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.gnome.org/sources/adwaita-icon-theme/3.16/adwaita-icon-theme-3.16.0.tar.xz
+ sha256sums = a3c8ad3b099ca571b423811a20ee9a7a43498cfa04d299719ee43cd7af6f6eb1
+
+pkgname = mingw-w64-adwaita-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0db993e80b3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: lantw44 at gmail dot com
+
+pkgname=mingw-w64-adwaita-icon-theme
+pkgver=3.16.0
+pkgrel=1
+pkgdesc="Adwaita icon theme (mingw-w64)"
+arch=(any)
+url="http://www.gnome.org"
+license=('GPL')
+makedepends=(
+ 'mingw-w64-configure'
+ 'intltool')
+depends=('mingw-w64-hicolor-icon-theme')
+options=(!strip !buildflags staticlibs)
+source=("https://download.gnome.org/sources/adwaita-icon-theme/${pkgver%.*}/adwaita-icon-theme-${pkgver}.tar.xz")
+sha256sums=('a3c8ad3b099ca571b423811a20ee9a7a43498cfa04d299719ee43cd7af6f6eb1')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/adwaita-icon-theme-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p "build-${_arch}"
+ cd "build-${_arch}"
+ ${_arch}-configure
+ make
+ cd ..
+ done
+}
+
+package() {
+ cd "${srcdir}/adwaita-icon-theme-${pkgver}"
+ for _arch in ${_architectures}; do
+ cd "build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' -o -name '*.manifest' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
+ find "$pkgdir/usr/${_arch}" -name '*.a' | xargs -rtl1 ${_arch}-strip -g
+ find "$pkgdir/usr/${_arch}/locale" -type d -empty -delete
+ cd ..
+ done
+}