summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlucas593562018-12-19 19:25:00 -0200
committerlucas593562018-12-19 19:25:00 -0200
commit5dbcd4db69b81e12636e6b91ba695c65c36bd9ee (patch)
tree6f76b1b3550ad456c6bf1c4e099b75dc8229673b
downloadaur-5dbcd4db69b81e12636e6b91ba695c65c36bd9ee.tar.gz
Working and tested building https://github.com/lucasew/allegro_blasteroids sucessfully.
Signed-off-by: lucas59356 <lucas59356@gmail.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33a6ebf309e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mingw-w64-allegro-static-bin
+ pkgdesc = Portable library mainly aimed at video game and multimedia programming. This is statically prebuilt
+ pkgver = 5.2.4.0
+ pkgrel = 0
+ url = https://liballeg.org/
+ arch = x86_64
+ license = custom
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/liballeg/allegro5/releases/download/5.2.4.0/allegro-x86_64-w64-mingw32-gcc-7.2.0-posix-seh-static-5.2.4.1.zip
+ sha256sums = 92ee2e110c2229c8489450af98076533abc399264ca25932a981aabe81c05548
+
+pkgname = mingw-w64-allegro-static-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b0ac303f350
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer:Lucas Eduardo Wendt <lucas59356@gmail.com>
+
+pkgname=mingw-w64-allegro-static-bin
+pkgver=5.2.4.0
+pkgrel=0
+arch=(x86_64)
+pkgdesc="Portable library mainly aimed at video game and multimedia programming. This is statically prebuilt"
+license=("custom")
+url="https://liballeg.org/"
+options=(!strip !buildflags staticlibs)
+source=("https://github.com/liballeg/allegro5/releases/download/5.2.4.0/allegro-x86_64-w64-mingw32-gcc-7.2.0-posix-seh-static-5.2.4.1.zip")
+
+sha256sums=('92ee2e110c2229c8489450af98076533abc399264ca25932a981aabe81c05548')
+
+package() {
+ DESTINATION=$pkgdir/usr/x86_64-w64-mingw32
+ mkdir -p $DESTINATION
+ cp -r $srcdir/allegro/* $DESTINATION
+}