summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-01-25 18:18:39 +0100
committerMichel Zou2018-01-25 18:18:39 +0100
commit46a071b4ceac81e77db95981046b63890cfbc80d (patch)
treef4a88e3b4eeb057d0ac40ee6afa5148665c42e23
parent1295767f3688167ebcfac2042705e4579951681f (diff)
downloadaur-46a071b4ceac81e77db95981046b63890cfbc80d.tar.gz
3.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9feb4dbce13..e9f19a019c1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Sep 13 16:35:23 UTC 2016
+# Thu Jan 25 17:18:39 UTC 2018
pkgbase = mingw-w64-arpack
pkgdesc = Fortran77 subroutines designed to solve large scale eigenvalue problems (mingw-w64)
- pkgver = 3.4.0
+ pkgver = 3.5.0
pkgrel = 1
url = http://forge.scilab.org/index.php/p/arpack-ng/
arch = any
@@ -12,8 +12,8 @@ pkgbase = mingw-w64-arpack
options = !buildflags
options = !strip
options = staticlibs
- source = git://github.com/opencollab/arpack-ng#tag=3.4.0
- sha256sums = SKIP
+ source = https://github.com/opencollab/arpack-ng/archive/3.5.0.tar.gz
+ sha256sums = 50f7a3e3aec2e08e732a487919262238f8504c3ef927246ec3495617dde81239
pkgname = mingw-w64-arpack
diff --git a/PKGBUILD b/PKGBUILD
index 074006aa7196..893af0277525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-arpack
-pkgver=3.4.0
+pkgver=3.5.0
pkgrel=1
arch=('any')
pkgdesc='Fortran77 subroutines designed to solve large scale eigenvalue problems (mingw-w64)'
@@ -9,18 +9,18 @@ license=('BSD')
depends=('mingw-w64-lapack')
makedepends=('mingw-w64-configure')
options=('!buildflags' '!strip' 'staticlibs')
-source=("git://github.com/opencollab/arpack-ng#tag=$pkgver")
-sha256sums=('SKIP')
+source=("https://github.com/opencollab/arpack-ng/archive/3.5.0.tar.gz")
+sha256sums=('50f7a3e3aec2e08e732a487919262238f8504c3ef927246ec3495617dde81239')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "$srcdir/arpack-ng"
+ cd "$srcdir/arpack-ng-${pkgver}"
./bootstrap
}
build() {
- cd "$srcdir/arpack-ng"
+ cd "$srcdir/arpack-ng-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p "build-${_arch}" && pushd "build-${_arch}"
${_arch}-configure
@@ -31,12 +31,11 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "$srcdir/arpack-ng/build-${_arch}"
+ cd "$srcdir/arpack-ng-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir/" install
chmod a-x "$pkgdir"/usr/${_arch}/lib/*.dll.a
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
- install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}