summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-08-17 18:28:32 -0700
committerSchala2016-08-17 18:28:32 -0700
commit0f95255bc39126f60f72eedec77b8d9e123e3f10 (patch)
tree38dc7b2f85beef3467c86f4538aa436285031732
parentb433dbfb3e53e3f968d651acfbd436c7043f3de3 (diff)
downloadaur-0f95255bc39126f60f72eedec77b8d9e123e3f10.tar.gz
only remove share/info/dir now
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84906f75b31a..627859a3c408 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Aug 18 01:27:55 UTC 2016
pkgbase = mingw-w64-aspell
pkgdesc = A spell checker designed to eventually replace Ispell (mingw-w64)
pkgver = 0.60.6.1
- pkgrel = 1
+ pkgrel = 2
url = http://aspell.net/
arch = any
license = LGPL
makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pdcurses-win32a
depends = mingw-w64-gettext
+ optdepends = mingw-w64-pdcurses-win32a
options = !strip
options = !buildflags
options = staticlibs
diff --git a/.gitignore b/.gitignore
index 25cca9a92b37..5b06d8419137 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
*.gz
+*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 8dd605645e0f..72bcaad17780 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
pkgname=mingw-w64-aspell
pkgver=0.60.6.1
_pkgmajorver=0.60
-pkgrel=1
+pkgrel=2
pkgdesc="A spell checker designed to eventually replace Ispell (mingw-w64)"
arch=(any)
url="http://aspell.net/"
license=("LGPL")
-makedepends=(mingw-w64-gcc)
+makedepends=(mingw-w64-gcc mingw-w64-pdcurses-win32a)
depends=(mingw-w64-gettext)
options=(!strip !buildflags staticlibs)
+optdepends=(mingw-w64-pdcurses-win32a)
source=("ftp://ftp.gnu.org/gnu/aspell/aspell-${pkgver}.tar.gz"
"0001-use-namespace.mingw.patch"
"0002-printf.mingw.patch"
@@ -60,8 +61,7 @@ build() {
--libdir=/usr/${_arch}/lib \
--includedir=/usr/${_arch}/include \
--enable-shared \
- --enable-static \
- --disable-curses
+ --enable-static
make
popd
done
@@ -72,10 +72,8 @@ package() {
cd "${srcdir}/build-${_arch}"
make -j1 DESTDIR="$pkgdir" install
ln -s "/usr/${_arch}/lib/aspell-$_pkgmajorver" "${pkgdir}/usr/${_arch}/lib/aspell"
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -o -name '*.exe' | xargs ${_arch}-strip --strip-unneeded
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- rm -r "$pkgdir/usr/${_arch}/share"
- rm "$pkgdir/usr/${_arch}/bin/"{aspell-import,precat,preunzip,prezip,run-with-aspell}
+ rm "$pkgdir/usr/${_arch}/share/info/dir"
done
}