summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2022-08-01 16:01:42 -0400
committerPatrick Northon2022-08-01 16:01:42 -0400
commit0645b823ae9e68614aecd0fd588e1f5f2e9dc019 (patch)
tree710748976328a45ec7010b4c653b40177ed660fd
parentebfb5df098fb24333da368567b0b2f278ef8bdc5 (diff)
downloadaur-0645b823ae9e68614aecd0fd588e1f5f2e9dc019.tar.gz
Correct compile errors.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f43dadf211c..99f809fec464 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-assimp
pkgdesc = Portable Open Source library to import various well-known 3D model formats in an uniform manner (mingw-w64)
pkgver = 5.2.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.assimp.org/
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index f7dae41b9757..6cb9fe9040ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=assimp
pkgname=mingw-w64-${_pkgname}
pkgver=5.2.4
-pkgrel=1
+pkgrel=2
pkgdesc="Portable Open Source library to import various well-known 3D model formats in an uniform manner (mingw-w64)"
arch=('any')
license=('BSD')
@@ -34,6 +34,14 @@ prepare ()
sed -i 's/LINK_DIRECTORIES/#nope/' 'tools/assimp_cmd/CMakeLists.txt'
sed -i 's/LINK_DIRECTORIES/#nope/' 'tools/assimp_view/CMakeLists.txt'
sed -i 's/LINK_DIRECTORIES/#nope/' 'test/CMakeLists.txt'
+
+ # Correct obvious bug
+ sed -i 's/vlist.push_back(\*tlist_i.end())/vlist.push_back(tlist_i.back())/' 'code/AssetLib/X3D/X3DImporter_Geometry2D.cpp'
+ sed -i 's/vlist.push_back(\*tlist_o.end())/vlist.push_back(tlist_o.back())/' 'code/AssetLib/X3D/X3DImporter_Geometry2D.cpp'
+ sed -i 's/if (sheen.sheenColorFactor == defaultSheenFactor)/if (sheen.sheenColorFactor[0] == defaultSheenFactor[0] \&\& sheen.sheenColorFactor[1] == defaultSheenFactor[1] \&\& sheen.sheenColorFactor[2] == defaultSheenFactor[2])/' 'code/AssetLib/glTF2/glTF2Exporter.cpp'
+
+ # Obviously incorrect code
+ sed -i 's|aaiFaces\[(\*iFace).iTexture\].push_back( 0 )|//nope|' 'code/AssetLib/SMD/SMDLoader.cpp'
}
build()