summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMykola Dimura2017-03-11 01:28:27 +0100
committerMykola Dimura2017-03-11 01:28:27 +0100
commit22172f035c56488b4c3811a1142c96be4d4bb365 (patch)
treecc9777117f1c71a4d756ce35eb22e241674d13ab
downloadaur-22172f035c56488b4c3811a1142c96be4d4bb365.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7cfbe89eaa2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-async++-git
+ pkgdesc = Async++ is a lightweight concurrency framework for C++11. (mingw-w64)
+ pkgver = r161.8ba15ed
+ pkgrel = 1
+ url = https://github.com/Amanieu/asyncplusplus
+ arch = any
+ license = MIT
+ makedepends = mingw-w64-cmake
+ makedepends = git
+ depends = mingw-w64-crt
+ depends = mingw-w64-gcc
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = mingw-w64-async++::git+https://github.com/Amanieu/asyncplusplus.git#branch=master
+ sha1sums = SKIP
+
+pkgname = mingw-w64-async++-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c125b69e487
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mykola Dimura <mykola.dimura@gmail.com>
+pkgname=mingw-w64-async++-git
+pkgver=r161.8ba15ed
+pkgrel=1
+pkgdesc="Async++ is a lightweight concurrency framework for C++11. (mingw-w64)"
+arch=('any')
+url='https://github.com/Amanieu/asyncplusplus'
+license=('MIT')
+depends=('mingw-w64-crt' 'mingw-w64-gcc')
+makedepends=('mingw-w64-cmake' 'git')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("${pkgname%-git}::git+https://github.com/Amanieu/asyncplusplus.git#branch=master")
+sha1sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/${pkgname%-git}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}