summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-09-10 16:34:00 -0400
committerAndrew Sun2019-09-10 16:34:00 -0400
commit02947d807d79159e0916741560908938d04a4ca9 (patch)
treeb4b1fc20c3915b1ce2e2999dd8c955d79e1bad92
parent354da638178009849a76bc508eed918c6461e909 (diff)
downloadaur-02947d807d79159e0916741560908938d04a4ca9.tar.gz
mingw-w64-atk: update to 2.34.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8d158b54031..4a34190d5d99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-atk
pkgdesc = Interface definitions of accessibility infrastructure (mingw-w64)
- pkgver = 2.34.0
+ pkgver = 2.34.1
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/atk
arch = any
@@ -8,14 +8,13 @@ pkgbase = mingw-w64-atk
makedepends = mingw-w64-gcc
makedepends = mingw-w64-meson
makedepends = python
- makedepends = git
depends = mingw-w64-crt
depends = mingw-w64-glib2
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://gitlab.gnome.org/GNOME/atk.git#commit=ae00132c6ef58d779e9389a10badb2f43ee35606
- sha256sums = SKIP
+ source = http://ftp.gnome.org/pub/gnome/sources/atk/2.34/atk-2.34.1.tar.xz
+ sha256sums = d4f0e3b3d21265fcf2bc371e117da51c42ede1a71f6db1c834e6976bb20997cb
pkgname = mingw-w64-atk
diff --git a/PKGBUILD b/PKGBUILD
index 516b52373534..af2417d5d452 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,22 @@
# Contributor: <nontlikeuname at tuta dot io>
pkgname=mingw-w64-atk
-pkgver=2.34.0
+pkgver=2.34.1
pkgrel=1
pkgdesc="Interface definitions of accessibility infrastructure (mingw-w64)"
arch=('any')
url="https://gitlab.gnome.org/GNOME/atk"
license=('LGPL')
-makedepends=('mingw-w64-gcc' 'mingw-w64-meson' 'python' 'git')
+makedepends=('mingw-w64-gcc' 'mingw-w64-meson' 'python')
depends=('mingw-w64-crt' 'mingw-w64-glib2')
options=('!strip' '!buildflags' 'staticlibs')
-_commit=ae00132c6ef58d779e9389a10badb2f43ee35606 # tags/ATK_2_34_00^0
-source=("git+https://gitlab.gnome.org/GNOME/atk.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("http://ftp.gnome.org/pub/gnome/sources/atk/${pkgver%.*}/atk-${pkgver}.tar.xz")
+sha256sums=('d4f0e3b3d21265fcf2bc371e117da51c42ede1a71f6db1c834e6976bb20997cb')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "${srcdir}/atk"
+ cd "${srcdir}/atk-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-meson \
@@ -35,7 +34,7 @@ build() {
package() {
for _arch in ${_architectures}; do
- DESTDIR="${pkgdir}" meson install -C ${srcdir}/atk/build-${_arch}
+ DESTDIR="${pkgdir}" meson install -C ${srcdir}/atk-${pkgver}/build-${_arch}
rm -r ${pkgdir}/usr/${_arch}/share