summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2022-10-02 12:14:33 -0400
committerPatrick Northon2022-10-02 12:14:33 -0400
commit5f8455d6d8ad82b1d4d0bc0f3bd346da52c52d9b (patch)
tree28fb8b2a3bc4773867c374393335720cba1b9dc8
parenta47b9c05bbcc7425906ea3e1b27c498313979ded (diff)
downloadaur-5f8455d6d8ad82b1d4d0bc0f3bd346da52c52d9b.tar.gz
Revamped and bumped version.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD63
2 files changed, 36 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee5f9ff6fcde..748fc3d006af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-blosc
pkgdesc = A blocking, shuffling and loss-less compression library (mingw-w64)
- pkgver = 1.17.1
+ pkgver = 1.21.1
pkgrel = 1
url = http://blosc.org/
arch = any
@@ -13,8 +13,7 @@ pkgbase = mingw-w64-blosc
options = !buildflags
options = !strip
options = staticlibs
- source = https://github.com/Blosc/c-blosc/archive/v1.17.1.tar.gz
- sha256sums = 19a6948b579c27e8ac440b4f077f99fc90e7292b1d9cb896bec0fd781d68fba2
+ source = blosc-1.21.1.tar.gz::https://github.com/Blosc/c-blosc/archive/refs/tags/v1.21.1.tar.gz
+ sha256sums = f387149eab24efa01c308e4cba0f59f64ccae57292ec9c794002232f7903b55b
pkgname = mingw-w64-blosc
-
diff --git a/PKGBUILD b/PKGBUILD
index 6e5cc69fefff..ced941bdb05b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,8 @@
-pkgname=mingw-w64-blosc
-pkgver=1.17.1
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+_pkgname=blosc
+pkgname=mingw-w64-${_pkgname}
+pkgver=1.21.1
pkgrel=1
pkgdesc="A blocking, shuffling and loss-less compression library (mingw-w64)"
url="http://blosc.org/"
@@ -8,42 +11,42 @@ arch=('any')
depends=('mingw-w64-zstd' 'mingw-w64-snappy' 'mingw-w64-lz4' 'mingw-w64-zlib')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
-source=("https://github.com/Blosc/c-blosc/archive/v${pkgver}.tar.gz")
-sha256sums=('19a6948b579c27e8ac440b4f077f99fc90e7292b1d9cb896bec0fd781d68fba2')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/Blosc/c-blosc/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('f387149eab24efa01c308e4cba0f59f64ccae57292ec9c794002232f7903b55b')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_srcdir="c-blosc-${pkgver}"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_C_FLAGS_RELEASE='-DNDEBUG'
+ -DPREFER_EXTERNAL_LZ4=ON
+ -DPREFER_EXTERNAL_ZLIB=ON
+ -DPREFER_EXTERNAL_ZSTD=ON
+ -DDEACTIVATE_AVX2=ON
+ -DBUILD_BENCHMARKS=OFF
+ -DBUILD_FUZZERS=OFF
+ -DDEACTIVATE_SNAPPY=OFF )
prepare() {
- cd "$srcdir/c-blosc-${pkgver}"
-
- # dont use bundled pthread (missing _WIN32_WINNT 0x0600 define)
- sed -i 's|#include "win32/pthread.h"|#include <pthread.h>|g' blosc/blosc.c blosc/shuffle.c
- sed -i 's|#include "win32/pthread.c"||g' blosc/blosc.c
+ cd "$_srcdir"
- sed -i 's|DESTINATION ${lib_dir}|LIBRARY DESTINATION ${lib_dir} ARCHIVE DESTINATION ${lib_dir} RUNTIME DESTINATION bin|g' blosc/CMakeLists.txt
+ # dont use bundled pthread (missing _WIN32_WINNT 0x0600 define)
+ sed -i 's|#include "win32/pthread.h"|#include <pthread.h>|g' blosc/blosc.c blosc/shuffle.c
+ sed -i 's|#include "win32/pthread.c"||g' blosc/blosc.c
}
build() {
- cd "$srcdir/c-blosc-${pkgver}"
- for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake \
- -DPREFER_EXTERNAL_LZ4="ON" \
- -DPREFER_EXTERNAL_ZLIB="ON" \
- -DPREFER_EXTERNAL_SNAPPY="ON" \
- -DPREFER_EXTERNAL_ZSTD="ON" \
- -DBUILD_TESTS="OFF" \
- ..
- make
- popd
- done
+ for _arch in ${_architectures}; do
+ ${_arch}-cmake -S "${_srcdir}" -B "build-${_arch}" "${_flags[@]}" \
+ -DBUILD_STATIC=ON \
+ -DBUILD_TESTS=OFF
+ cmake --build "build-${_arch}"
+ done
}
package() {
- for _arch in ${_architectures}; do
- cd "$srcdir/c-blosc-${pkgver}/build-${_arch}"
- make install DESTDIR="$pkgdir"
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
- done
+ for _arch in ${_architectures}; do
+ DESTDIR="${pkgdir}" cmake --install "build-${_arch}"
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
}