summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-06-09 18:09:08 +0200
committerMichel Zou2021-06-09 18:09:08 +0200
commit182fa02f606780ccbc2b2075b7fad04c93211c49 (patch)
tree42bcb6c8f39089699c4dabc2514d5a49bdc9605f
parenteca5fa228216edf3fd69572140d2adae99489a25 (diff)
downloadaur-182fa02f606780ccbc2b2075b7fad04c93211c49.tar.gz
enable thread_local
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fee7fcc63521..b1c831cdfd82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-boost
pkgdesc = Free peer-reviewed portable C++ source libraries (mingw-w64)
pkgver = 1.75.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.boost.org/
arch = any
license = custom
@@ -21,4 +21,3 @@ pkgbase = mingw-w64-boost
sha256sums = 333791abd17ea192e0aa90185bfb8938e8e3dc102b284db316b061b2067e2fc2
pkgname = mingw-w64-boost
-
diff --git a/PKGBUILD b/PKGBUILD
index b3f5e20f4917..aa22366adee3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-boost
pkgver=1.75.0
_boostver=${pkgver//./_}
-pkgrel=1
+pkgrel=2
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
arch=('any')
url="http://www.boost.org/"
@@ -30,6 +30,9 @@ prepare() {
# https://github.com/boostorg/context/issues/136
curl -L https://github.com/boostorg/context/commit/85783e8cbba03804e13b3d314112df6b089ed2c0.patch | patch -p1 -R -d libs/context
+ # enable thread_local with gcc 11.x
+ curl -L https://github.com/boostorg/config/pull/380.patch | patch -p2
+
cd "${srcdir}"
for _arch in ${_architectures}; do
rm -rf build-${_arch:3}