summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-04-28 19:02:19 +0200
committerMichel Zou2020-04-28 19:02:19 +0200
commit478083d45cce6df2c8b6156e36f56ac046f33b76 (patch)
tree74c2c4d3d1e9a351bf03c3b6db245fe7621c171d
parent72c42787b53de6a7fbabe13ddf18c86a26782e84 (diff)
downloadaur-478083d45cce6df2c8b6156e36f56ac046f33b76.tar.gz
1.73.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--context-cross.patch (renamed from boost-mingw.patch)16
-rw-r--r--jam-wine.patch25
-rw-r--r--stacktrace-cross.patch12
5 files changed, 40 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35ad8473cb6a..2881b986b592 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-boost
pkgdesc = Free peer-reviewed portable C++ source libraries (mingw-w64)
- pkgver = 1.72.0
+ pkgver = 1.73.0
pkgrel = 1
url = http://www.boost.org/
arch = any
@@ -13,12 +13,12 @@ pkgbase = mingw-w64-boost
options = !strip
options = !buildflags
options = staticlibs
- source = https://dl.bintray.com/boostorg/release/1.72.0/source/boost_1_72_0.tar.bz2
- source = boost-mingw.patch
- source = jam-wine.patch
- sha256sums = 59c9b274bc451cf91a9ba1dd2c7fdcaf5d60b1b3aa83f2c9fa143417cc660722
- sha256sums = 11a5c39852e0513d871a0f74c2f1224efc602a0404db7cd83190712e49a6d3bc
- sha256sums = 5ca770bf155dbed4f96b1fcd358d515ad77a1ca7ae5e6d6b180939beceff05af
+ source = https://dl.bintray.com/boostorg/release/1.73.0/source/boost_1_73_0.tar.bz2
+ source = context-cross.patch
+ source = stacktrace-cross.patch
+ sha256sums = 4eb3b8d442b426dc35346235c8733b5ae35ba431690e38c6a8263dce9fcbb402
+ sha256sums = 844e163845ea6e7ae1f8d26cb52f72c6e4645cdade1be081bc1d2cff5db0a918
+ sha256sums = 333791abd17ea192e0aa90185bfb8938e8e3dc102b284db316b061b2067e2fc2
pkgname = mingw-w64-boost
diff --git a/PKGBUILD b/PKGBUILD
index 431312202cfe..74bb632ceb4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-boost
-pkgver=1.72.0
+pkgver=1.73.0
_boostver=${pkgver//./_}
pkgrel=1
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
@@ -10,10 +10,10 @@ depends=('mingw-w64-zstd' 'mingw-w64-bzip2' 'mingw-w64-libbacktrace-git')
makedepends=('mingw-w64-gcc' 'mingw-w64-wine')
options=('!strip' '!buildflags' 'staticlibs')
source=("https://dl.bintray.com/boostorg/release/${pkgver}/source/boost_${_boostver}.tar.bz2"
- "boost-mingw.patch" "jam-wine.patch")
-sha256sums=('59c9b274bc451cf91a9ba1dd2c7fdcaf5d60b1b3aa83f2c9fa143417cc660722'
- '11a5c39852e0513d871a0f74c2f1224efc602a0404db7cd83190712e49a6d3bc'
- '5ca770bf155dbed4f96b1fcd358d515ad77a1ca7ae5e6d6b180939beceff05af')
+ "context-cross.patch" "stacktrace-cross.patch")
+sha256sums=('4eb3b8d442b426dc35346235c8733b5ae35ba431690e38c6a8263dce9fcbb402'
+ '844e163845ea6e7ae1f8d26cb52f72c6e4645cdade1be081bc1d2cff5db0a918'
+ '333791abd17ea192e0aa90185bfb8938e8e3dc102b284db316b061b2067e2fc2')
_architectures="32:i686-w64-mingw32 64:x86_64-w64-mingw32"
@@ -22,10 +22,13 @@ prepare() {
cd "${srcdir}/boost_${_boostver}"
# https://svn.boost.org/trac/boost/ticket/7262
- patch -Np0 -i "${srcdir}"/boost-mingw.patch
+ patch -p1 -d libs/context -i "${srcdir}"/context-cross.patch
- # run jam exes through wine (eg for libbacktrace detection)
- patch -p1 -i "${srcdir}"/jam-wine.patch
+ # bypass libbacktrace detection
+ patch -p1 -d libs/stacktrace -i "${srcdir}"/stacktrace-cross.patch
+
+ # https://github.com/boostorg/context/issues/136
+ curl -L https://github.com/boostorg/context/commit/85783e8cbba03804e13b3d314112df6b089ed2c0.patch | patch -p1 -R -d libs/context
cd "${srcdir}"
for _arch in ${_architectures}; do
@@ -49,7 +52,6 @@ package() {
cd "${srcdir}"
for _arch in ${_architectures}; do
pushd "build-${_arch:3}"
- export BOOST_CROSSCOMPILING_EMULATOR=/usr/bin/${_arch:3}-wine
LD_PRELOAD="" ./b2 -d2 -q ${MAKEFLAGS} \
target-os=windows \
variant=release \
diff --git a/boost-mingw.patch b/context-cross.patch
index 9613e46b0df1..c14591af804d 100644
--- a/boost-mingw.patch
+++ b/context-cross.patch
@@ -1,6 +1,8 @@
---- libs/context/build/Jamfile.v2.orig 2013-03-03 13:39:59.684868916 +0100
-+++ libs/context/build/Jamfile.v2 2013-03-03 15:09:09.893232829 +0100
-@@ -45,10 +45,11 @@
+diff --git a/build/Jamfile.v2 b/build/Jamfile.v2
+index 580aca6..572148f 100644
+--- a/build/Jamfile.v2
++++ b/build/Jamfile.v2
+@@ -52,10 +52,11 @@ project boost/context
local rule default_binary_format ( )
{
local tmp = elf ;
@@ -16,18 +18,20 @@
return $(tmp) ;
}
-@@ -65,10 +66,11 @@
+@@ -72,11 +73,12 @@ feature.set-default binary-format : [ default_binary_format ] ;
local rule default_abi ( )
{
local tmp = sysv ;
- if [ os.name ] = "NT" { tmp = ms ; }
- else if [ os.name ] = "CYGWIN" { tmp = ms ; }
- else if [ os.platform ] = "ARM" { tmp = aapcs ; }
-- else if [ os.platform ] = "MIPS" { tmp = o32 ; }
+- else if [ os.platform ] = "MIPS32" { tmp = o32 ; }
+- else if [ os.platform ] = "MIPS64" { tmp = n64 ; }
+ #if [ os.name ] = "NT" { tmp = ms ; }
+ #else if [ os.name ] = "CYGWIN" { tmp = ms ; }
+ #else if [ os.platform ] = "ARM" { tmp = aapcs ; }
-+ #else if [ os.platform ] = "MIPS" { tmp = o32 ; }
++ #else if [ os.platform ] = "MIPS32" { tmp = o32 ; }
++ #else if [ os.platform ] = "MIPS64" { tmp = n64 ; }
+ tmp = ms ;
return $(tmp) ;
}
diff --git a/jam-wine.patch b/jam-wine.patch
deleted file mode 100644
index b990004fde0c..000000000000
--- a/jam-wine.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/build/Jamfile.v2 b/build/Jamfile.v2
-index 6d6d85a..745162d 100644
---- a/libs/stacktrace/build/Jamfile.v2
-+++ b/libs/stacktrace/build/Jamfile.v2
-@@ -15,6 +15,7 @@ lib dl ;
- lib gcc_s ;
- lib Dbgeng ;
- lib ole32 ;
-+import os ;
-
-
- local LIBBACKTRACE_PATH = [ modules.peek : LIBBACKTRACE_PATH ] ;
-@@ -25,9 +26,11 @@ lib backtrace
- : <include>$(LIBBACKTRACE_PATH)/include
- ;
-
-+local BOOST_CROSSCOMPILING_EMULATOR = [ os.environ BOOST_CROSSCOMPILING_EMULATOR ] ;
-+
- actions mp_simple_run_action
- {
-- $(>) > $(<)
-+ $(BOOST_CROSSCOMPILING_EMULATOR) $(>) > $(<)
- }
-
- rule mp-run-simple ( sources + : args * : input-files * : requirements * : target-name )
diff --git a/stacktrace-cross.patch b/stacktrace-cross.patch
new file mode 100644
index 000000000000..e8b9628f1426
--- /dev/null
+++ b/stacktrace-cross.patch
@@ -0,0 +1,12 @@
+diff --git a/build/Jamfile.v2 b/build/Jamfile.v2
+index 6d6d85a..c5ee926 100644
+--- a/build/Jamfile.v2
++++ b/build/Jamfile.v2
+@@ -74,7 +74,6 @@ lib boost_stacktrace_backtrace
+ <target-os>linux:<library>dl
+ <library>backtrace
+ <link>shared:<define>BOOST_STACKTRACE_DYN_LINK=1
+- [ check-target-builds ../build//libbacktrace : : <build>no ]
+ : # default build
+ : # usage-requirements
+ #<link>shared:<define>BOOST_STACKTRACE_DYN_LINK=1