summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-11-29 22:33:18 +0100
committerMichel Zou2019-11-29 22:33:18 +0100
commit4f84df88d6943338c5236ad4b24184458a511bbe (patch)
treebb79c9a2382abaecf992a11e284a7b3a2c19e041
parentd7b3b10ce046edb57cec2e0b9f37971dccf8f001 (diff)
downloadaur-4f84df88d6943338c5236ad4b24184458a511bbe.tar.gz
stacktrace-backtrace
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--jam-wine.patch26
3 files changed, 41 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c68afa4754f1..15270911978a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = mingw-w64-boost
pkgdesc = Free peer-reviewed portable C++ source libraries (mingw-w64)
pkgver = 1.71.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.boost.org/
arch = any
license = custom
makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-wine
depends = mingw-w64-zstd
depends = mingw-w64-bzip2
+ depends = mingw-w64-libbacktrace-git
options = !strip
options = !buildflags
options = staticlibs
source = https://dl.bintray.com/boostorg/release/1.71.0/source/boost_1_71_0.tar.bz2
source = boost-mingw.patch
+ source = jam-wine.patch
sha256sums = d73a8da01e8bf8c7eda40b4c84915071a8c8a0df4a6734537ddde4a8580524ee
sha256sums = 11a5c39852e0513d871a0f74c2f1224efc602a0404db7cd83190712e49a6d3bc
+ sha256sums = 8af7d7fb6e45b0ded273415824ff56878a73800a067188327cf0fa351352bec1
pkgname = mingw-w64-boost
diff --git a/PKGBUILD b/PKGBUILD
index f1550e0bbfb6..ccbea20e0986 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
pkgname=mingw-w64-boost
pkgver=1.71.0
_boostver=${pkgver//./_}
-pkgrel=2
+pkgrel=3
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
arch=('any')
url="http://www.boost.org/"
license=('custom')
-depends=('mingw-w64-zstd' 'mingw-w64-bzip2')
-makedepends=('mingw-w64-gcc')
+depends=('mingw-w64-zstd' 'mingw-w64-bzip2' 'mingw-w64-libbacktrace-git')
+makedepends=('mingw-w64-gcc' 'mingw-w64-wine')
options=('!strip' '!buildflags' 'staticlibs')
source=("https://dl.bintray.com/boostorg/release/${pkgver}/source/boost_${_boostver}.tar.bz2"
- "boost-mingw.patch")
+ "boost-mingw.patch" "jam-wine.patch")
sha256sums=('d73a8da01e8bf8c7eda40b4c84915071a8c8a0df4a6734537ddde4a8580524ee'
- '11a5c39852e0513d871a0f74c2f1224efc602a0404db7cd83190712e49a6d3bc')
+ '11a5c39852e0513d871a0f74c2f1224efc602a0404db7cd83190712e49a6d3bc'
+ '8af7d7fb6e45b0ded273415824ff56878a73800a067188327cf0fa351352bec1')
_architectures="32:i686-w64-mingw32 64:x86_64-w64-mingw32"
@@ -23,6 +24,9 @@ prepare() {
# https://svn.boost.org/trac/boost/ticket/7262
patch -Np0 -i "${srcdir}"/boost-mingw.patch
+ # run jam exes through wine (eg for libbacktrace detection)
+ patch -p1 -i "${srcdir}"/jam-wine.patch
+
cd "${srcdir}"
for _arch in ${_architectures}; do
rm -rf build-${_arch:3}
@@ -45,6 +49,7 @@ package() {
cd "${srcdir}"
for _arch in ${_architectures}; do
pushd "build-${_arch:3}"
+ export BOOST_CROSSCOMPILING_EMULATOR=/usr/bin/${_arch:3}-wine
./b2 -d2 -q ${MAKEFLAGS} \
target-os=windows \
variant=release \
diff --git a/jam-wine.patch b/jam-wine.patch
new file mode 100644
index 000000000000..91154a734090
--- /dev/null
+++ b/jam-wine.patch
@@ -0,0 +1,26 @@
+diff --git a/build/Jamfile.v2 b/build/Jamfile.v2
+index 6d6d85a..2e53a9e 100644
+--- a/libs/stacktrace/build/Jamfile.v2
++++ b/libs/stacktrace/build/Jamfile.v2
+@@ -15,6 +15,7 @@ lib dl ;
+ lib gcc_s ;
+ lib Dbgeng ;
+ lib ole32 ;
++import os ;
+
+
+ local LIBBACKTRACE_PATH = [ modules.peek : LIBBACKTRACE_PATH ] ;
+@@ -25,9 +26,12 @@ lib backtrace
+ : <include>$(LIBBACKTRACE_PATH)/include
+ ;
+
++local BOOST_CROSSCOMPILING_EMULATOR = [ os.environ BOOST_CROSSCOMPILING_EMULATOR ] ;
++
+ actions mp_simple_run_action
+ {
+- $(>) > $(<)
++ $(BOOST_CROSSCOMPILING_EMULATOR) $(>) > $(<)
++ ls $(<)
+ }
+
+ rule mp-run-simple ( sources + : args * : input-files * : requirements * : target-name )