summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-05-14 18:09:50 +0200
committerMichel Zou2016-05-14 18:09:50 +0200
commit5011a13d3703767c399e46684679b09484ccaa99 (patch)
treed8b1065cd7d5bc3cbff2222e918ac2f5b8473580
parent14b105b383fcd9d009fcfd4f0b209fa506155aa1 (diff)
downloadaur-5011a13d3703767c399e46684679b09484ccaa99.tar.gz
v1.61
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--boost-mingw.patch36
3 files changed, 15 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37c78cb72c29..c55014611a87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 24 08:02:28 UTC 2015
+# Sat May 14 16:09:50 UTC 2016
pkgbase = mingw-w64-boost
pkgdesc = Free peer-reviewed portable C++ source libraries (mingw-w64)
- pkgver = 1.60.0
+ pkgver = 1.61.0
pkgrel = 1
url = http://www.boost.org/
arch = any
@@ -17,10 +17,10 @@ pkgbase = mingw-w64-boost
options = !strip
options = !buildflags
options = staticlibs
- source = http://downloads.sourceforge.net/boost/boost/1.60.0/boost_1_60_0.tar.bz2
+ source = http://downloads.sourceforge.net/boost/boost/1.61.0/boost_1_61_0.tar.bz2
source = boost-mingw.patch
- md5sums = 65a840e1a0b13a558ff19eeb2c4f0cbe
- md5sums = 30f8a21c4835ab0e729a1b7f08137bc1
+ md5sums = 6095876341956f65f9d35939ccea1a9f
+ md5sums = 3cf0110f7eac62f57178515c7dee9b66
pkgname = mingw-w64-boost
diff --git a/PKGBUILD b/PKGBUILD
index 7277588b69fa..6083c3be8f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Daniel Kirchner <daniel@ekpyron.org>
pkgname=mingw-w64-boost
-pkgver=1.60.0
+pkgver=1.61.0
_boostver=${pkgver//./_}
pkgrel=1
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
@@ -10,11 +10,11 @@ url="http://www.boost.org/"
license=('custom')
depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-bzip2')
makedepends=('mingw-w64-gcc' 'bzip2' 'zlib' 'python2')
-options=(!strip !buildflags staticlibs)
+options=('!strip' '!buildflags' 'staticlibs')
source=("http://downloads.sourceforge.net/boost/boost/${pkgver}/boost_${_boostver}.tar.bz2"
- boost-mingw.patch)
-md5sums=('65a840e1a0b13a558ff19eeb2c4f0cbe'
- '30f8a21c4835ab0e729a1b7f08137bc1')
+ "boost-mingw.patch")
+md5sums=('6095876341956f65f9d35939ccea1a9f'
+ '3cf0110f7eac62f57178515c7dee9b66')
_architectures="32:i686-w64-mingw32 64:x86_64-w64-mingw32"
@@ -24,6 +24,11 @@ prepare() {
# https://svn.boost.org/trac/boost/ticket/7262
patch -Np0 -i "${srcdir}"/boost-mingw.patch
+ # https://svn.boost.org/trac/boost/ticket/12205
+ cd libs/serialization
+ wget -c https://github.com/boostorg/serialization/pull/42.patch
+ patch -p1 -i 42.patch
+
cd "${srcdir}"
for _arch in ${_architectures}; do
rm -rf build-${_arch:3}
diff --git a/boost-mingw.patch b/boost-mingw.patch
index 69d56d007184..d086fa6d9bb5 100644
--- a/boost-mingw.patch
+++ b/boost-mingw.patch
@@ -44,39 +44,3 @@
return $(tmp) ;
}
---- libs/context/src/asm/jump_i386_ms_pe_gas.asm.mingw 2015-09-02 16:03:06.406321632 +0200
-+++ libs/context/src/asm/jump_i386_ms_pe_gas.asm 2015-09-02 16:04:17.632915315 +0200
-@@ -138,3 +138,6 @@
-
- /* indirect jump to context */
- jmp *%edx
-+
-+.section .drectve
-+.ascii " -export:\"jump_fcontext\""
---- libs/context/src/asm/jump_x86_64_ms_pe_gas.asm.mingw 2015-09-02 16:03:13.495380721 +0200
-+++ libs/context/src/asm/jump_x86_64_ms_pe_gas.asm 2015-09-02 16:04:12.488872439 +0200
-@@ -223,3 +223,6 @@
- /* indirect jump to context */
- jmp *%r10
- .seh_endproc
-+
-+.section .drectve
-+.ascii " -export:\"jump_fcontext\""
---- libs/context/src/asm/make_i386_ms_pe_gas.asm.mingw 2015-09-02 16:03:22.486455662 +0200
-+++ libs/context/src/asm/make_i386_ms_pe_gas.asm 2015-09-02 16:04:32.409038476 +0200
-@@ -122,3 +122,6 @@
- hlt
-
- .def __exit; .scl 2; .type 32; .endef /* standard C library function */
-+
-+.section .drectve
-+.ascii " -export:\"make_fcontext\""
---- libs/context/src/asm/make_x86_64_ms_pe_gas.asm.mingw 2015-09-02 16:03:30.631523552 +0200
-+++ libs/context/src/asm/make_x86_64_ms_pe_gas.asm 2015-09-02 16:04:27.433997008 +0200
-@@ -149,3 +149,6 @@
- .seh_endproc
-
- .def _exit; .scl 2; .type 32; .endef /* standard C library function */
-+
-+.section .drectve
-+.ascii " -export:\"make_fcontext\""