summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-08-13 22:28:59 +0200
committerxantares2015-08-13 22:28:59 +0200
commit61f5a35816cccb726773c9b567ba7e8342f0ccb8 (patch)
treef9cb67fd99b2dbfd2998dd8ea9b48dbf6b49ad82
parent2c4de1a0c9098071e83dcfd683f166b0a233ecd7 (diff)
downloadaur-61f5a35816cccb726773c9b567ba7e8342f0ccb8.tar.gz
update to 1.59.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c16ca0962187..cc0d2963e421 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-boost
pkgdesc = Free peer-reviewed portable C++ source libraries (mingw-w64)
- pkgver = 1.58.0
- pkgrel = 2
+ pkgver = 1.59.0
+ pkgrel = 1
url = http://www.boost.org/
arch = any
license = custom
@@ -15,9 +15,9 @@ pkgbase = mingw-w64-boost
options = !strip
options = !buildflags
options = staticlibs
- source = http://downloads.sourceforge.net/boost/boost/1.58.0/boost_1_58_0.tar.bz2
+ source = http://downloads.sourceforge.net/boost/boost/1.59.0/boost_1_59_0.tar.bz2
source = boost-mingw.patch
- md5sums = b8839650e61e9c1c0a89f371dd475546
+ md5sums = 6aa9a5c6a4ca1016edd0ed1178e3cb87
md5sums = 01f5f0d6b915d3b04dbabfd6db40f1e9
pkgname = mingw-w64-boost
diff --git a/PKGBUILD b/PKGBUILD
index ff23ed868fcb..3ff12de2fa45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Contributor: Daniel Kirchner <daniel@ekpyron.org>
pkgname=mingw-w64-boost
-pkgver=1.58.0
+pkgver=1.59.0
_boostver=${pkgver//./_}
-pkgrel=2
+pkgrel=1
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
arch=('any')
url="http://www.boost.org/"
@@ -11,8 +11,8 @@ license=('custom')
depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-bzip2')
makedepends=('mingw-w64-gcc' 'bzip2' 'zlib' 'python2')
options=(!strip !buildflags staticlibs)
-source=("http://downloads.sourceforge.net/boost/boost/1.58.0/boost_1_58_0.tar.bz2" boost-mingw.patch)
-md5sums=('b8839650e61e9c1c0a89f371dd475546'
+source=("http://downloads.sourceforge.net/boost/boost/${pkgver}/boost_${_boostver}.tar.bz2" boost-mingw.patch)
+md5sums=('6aa9a5c6a4ca1016edd0ed1178e3cb87'
'01f5f0d6b915d3b04dbabfd6db40f1e9')
_architectures="32:i686-w64-mingw32 64:x86_64-w64-mingw32"
@@ -24,10 +24,9 @@ prepare() {
# https://svn.boost.org/trac/boost/ticket/7262
patch -Np0 -i "${srcdir}"/boost-mingw.patch
- # had to disable context, coroutine: https://github.com/boostorg/context/issues/16
- # --without-libraries=...coroutine, see below
+ # disabled context, coroutine: https://github.com/boostorg/context/issues/16
- # had to pass BOOST_NO_CXX11_CHAR[16|32]_T since gcc 5
+ # disabled serialization: http://lists.boost.org/Archives/boost/2015/07/224242.php
cd "${srcdir}"
for _arch in ${_architectures}; do
@@ -60,11 +59,10 @@ package() {
runtime-link=shared \
--prefix=${pkgdir}/usr/${_arch:3} \
--user-config=user-config.jam \
- --without-mpi \
--without-python \
- --without-graph_parallel \
- --without-context --without-coroutine \
- define="BOOST_NO_CXX11_CHAR16_T -DBOOST_NO_CXX11_CHAR32_T" \
+ --without-mpi --without-graph_parallel \
+ --without-context --without-coroutine --without-coroutine2 \
+ --without-serialization \
cxxflags="-std=c++11 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4" \
address-model=${_arch:0:2} \
architecture=x86 \