summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-08-19 21:48:10 +0200
committerMichel Zou2017-08-19 21:48:10 +0200
commit06dddf1999d7850d8eca179735a339e0aa086710 (patch)
treeb30df80f0d082b533bde58f6517bffcbe775570d
parentf9b589a7a92511f37ace2c65caf26f7b03cd65ea (diff)
downloadaur-06dddf1999d7850d8eca179735a339e0aa086710.tar.gz
2.86.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a69882709683..bdbae7188c0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Dec 17 10:07:56 UTC 2016
+# Sat Aug 19 19:48:09 UTC 2017
pkgbase = mingw-w64-bullet
pkgdesc = A 3D Collision Detection and Rigid Body Dynamics Library for games and animation (mingw-w64)
- pkgver = 2.85.1
+ pkgver = 2.86.1
pkgrel = 1
url = http://www.bulletphysics.com/Bullet/
arch = any
@@ -12,8 +12,8 @@ pkgbase = mingw-w64-bullet
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/bulletphysics/bullet3/archive/2.85.1.tar.gz
- md5sums = 194cf1ef1eeb7fa9ac7dc580219d3c8b
+ source = https://github.com/bulletphysics/bullet3/archive/2.86.1.tar.gz
+ sha1sums = d0a4878ccc166902f0dcb822669d1a8e4ccc8642
pkgname = mingw-w64-bullet
diff --git a/PKGBUILD b/PKGBUILD
index 7977d3708ea9..5541d8e36d55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Paul Bienkowski <opatutlol@aol.com>
# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
pkgname=mingw-w64-bullet
-pkgver=2.85.1
+pkgver=2.86.1
pkgrel=1
pkgdesc="A 3D Collision Detection and Rigid Body Dynamics Library for games and animation (mingw-w64)"
arch=('any')
@@ -13,13 +13,12 @@ depends=('mingw-w64-crt')
options=('!strip' '!buildflags' 'staticlibs')
makedepends=('mingw-w64-cmake')
source=("https://github.com/bulletphysics/bullet3/archive/${pkgver}.tar.gz")
-md5sums=('194cf1ef1eeb7fa9ac7dc580219d3c8b')
+sha1sums=('d0a4878ccc166902f0dcb822669d1a8e4ccc8642')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd ${srcdir}/bullet3-${pkgver}
- #sed -i "s|#define SIMD_EPSILON FLT_EPSILON|#define SIMD_EPSILON 1.19209290E-07F|g" src/LinearMath/btScalar.h
}
build() {
@@ -27,8 +26,6 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
- -DBUILD_SHARED_LIBS=1 \
- -DBUILD_EXTRAS=1 \
-DBUILD_CPU_DEMOS=OFF \
-DBUILD_BULLET2_DEMOS=OFF \
-DBUILD_OPENGL3_DEMOS=OFF \
@@ -36,8 +33,6 @@ build() {
-DINSTALL_LIBS=1 \
-DUSE_GLUT=0 \
-DINSTALL_EXTRA_LIBS=1 \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_CXX_FLAGS_RELEASE="-fpermissive" \
..
make
popd
@@ -52,5 +47,4 @@ package() {
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
- install -Dm644 "${srcdir}"/bullet3-${pkgver}/LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}