summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Vries2020-10-11 12:44:07 +0200
committerMaarten de Vries2020-10-11 12:47:15 +0200
commit3ca52e8eb8f3c7649024a05b806466ae93f8bd87 (patch)
treecdbec05a3889c3f0664fdf4be54caf28fddd1aa7
parent556395bc041458d621f4d9a6d5d96ebfbdbb6afd (diff)
downloadaur-3ca52e8eb8f3c7649024a05b806466ae93f8bd87.tar.gz
Improve PKGBUILD, build shared libs.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6476424c4829..d01a9d2fd114 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = mingw-w64-capnproto
- pkgdesc = Cap'n Proto serialization/RPC system
+ pkgdesc = Cap'n Proto serialization/RPC system (mingw-w64)
pkgver = 0.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://capnproto.org/
- arch = i686
- arch = x86_64
+ arch = any
license = MIT
makedepends = mingw-w64-configure
+ makedepends = capnproto
+ depends = mingw-w64-crt
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index a564d2747985..dc6e49f8ae8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
# Contributors: Dave Reisner <dreisner@archlinux.org>
# Matthias Blaicher <matthias@blaicher.com>
# Severen Redwood <severen@shrike.me>
+# Xantares (AUR user)
pkgname=mingw-w64-capnproto
pkgver=0.7.0
-pkgrel=1
-pkgdesc="Cap'n Proto serialization/RPC system"
-arch=('i686' 'x86_64')
+pkgrel=2
+pkgdesc="Cap'n Proto serialization/RPC system (mingw-w64)"
+arch=('any')
url='https://capnproto.org/'
license=('MIT')
-makedepends=(mingw-w64-configure)
+makedepends=(mingw-w64-configure capnproto)
+depends=(mingw-w64-crt)
source=("https://capnproto.org/capnproto-c++-${pkgver}.tar.gz")
sha512sums=('9f8fb5753155798fcf9377a87f984a54d9fc5157c41aa11cd94108a773ca22d6e6952657e2d8079c9806f7de06f316c94957329fa52dbab6207aaa3b52348f04')
@@ -23,7 +25,7 @@ build() {
cd "$srcdir/capnproto-c++-$pkgver"
for _arch in ${_architectures[@]}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure --with-external-capnp --disable-shared --enable-static --disable-reflection
+ ${_arch}-configure --with-external-capnp --enable-shared --enable-static --disable-reflection
make
popd
done
@@ -33,7 +35,8 @@ package() {
for _arch in ${_architectures[@]}; do
cd "${srcdir}/capnproto-c++-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/lib/*.dll
+ ${_arch}-strip --strip-debug "$pkgdir"/usr/${_arch}/lib/*.a
done
}