summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjulienCXX2015-07-23 14:38:34 +0200
committerjulienCXX2015-07-23 14:38:34 +0200
commitfcaf4852728be5a69be044ea4186133b7b1f84c2 (patch)
tree0648a127d8ca9def0c5f44552710a001ac8a421e
downloadaur-fcaf4852728be5a69be044ea4186133b7b1f84c2.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--0001-Add-autoconfiguration-for-libjansson.patch58
-rw-r--r--PKGBUILD70
-rw-r--r--libccnet.pc.patch8
4 files changed, 170 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7dd11b84d7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = mingw-w64-ccnet
+ pkgdesc = A framework for writing networked applications in C (mingw-w64).
+ pkgver = 4.2.3
+ pkgrel = 4
+ url = https://github.com/haiwen/ccnet/
+ arch = any
+ license = custom
+ makedepends = mingw-w64-configure
+ makedepends = vala>=0.8
+ makedepends = python2>=2.6
+ depends = mingw-w64-crt
+ depends = mingw-w64-libevent>=2.0
+ depends = mingw-w64-glib2>=2.26.0
+ depends = mingw-w64-libsearpc
+ depends = mingw-w64-winpthreads
+ depends = mingw-w64-jansson>=2.2.1
+ depends = mingw-w64-sqlite
+ depends = mingw-w64-openssl
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = ccnet-4.2.3.tar.gz::https://github.com/haiwen/ccnet/archive/v4.2.3.tar.gz
+ source = libccnet.pc.patch
+ source = 0001-Add-autoconfiguration-for-libjansson.patch
+ source = ccnet-pull-86.patch::https://patch-diff.githubusercontent.com/raw/haiwen/ccnet/pull/86.patch
+ source = ccnet-pull-87.patch::https://patch-diff.githubusercontent.com/raw/haiwen/ccnet/pull/87.patch
+ sha256sums = 7da578ed4b04b99673c711cf22a9dc535e31c6f323e5701348211129be48c92d
+ sha256sums = 66c3b02c3981db6a80819e0ae103bedadf8dfdf81405a7f75a9cba714acf973f
+ sha256sums = 382b1da33e2b6c0ebab8d3921d92b7417fa11d969ad822cd43aee499fd7b3d94
+ sha256sums = b5c4cea9c718cf0e2e32572068ec9da4dc26cac7cfc1597eceff4aa53a4d0156
+ sha256sums = 1ea5f5555c6472afcbf6ad58b0ebdd86e5b58db0a848576f8b74c100083a8b7d
+
+pkgname = mingw-w64-ccnet
+
diff --git a/0001-Add-autoconfiguration-for-libjansson.patch b/0001-Add-autoconfiguration-for-libjansson.patch
new file mode 100644
index 000000000000..21774ff6e32c
--- /dev/null
+++ b/0001-Add-autoconfiguration-for-libjansson.patch
@@ -0,0 +1,58 @@
+diff --git a/configure.ac b/configure.ac
+index d7ebba9..3c1be4b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -241,6 +241,7 @@ APPINDICATOR_REQUIRED=0.0.7
+ GLIB_REQUIRED=2.16.0
+ GTK_REQUIRED=2.16.0
+ SEARPC_REQUIRED=1.0
++JANSSON_REQUIRED=2.2.1
+ ZDB_REQUIRED=2.10
+ LIBNAUTILUS_EXTENSION_REQUIRED=2.30.1
+ SEARPC_REQUIRED=1.0
+@@ -262,6 +263,10 @@ PKG_CHECK_MODULES(SEARPC, [libsearpc >= $SEARPC_REQUIRED])
+ AC_SUBST(SEARPC_CFLAGS)
+ AC_SUBST(SEARPC_LIBS)
+
++PKG_CHECK_MODULES(JANSSON, [jansson >= $JANSSON_REQUIRED])
++AC_SUBST(JANSSON_CFLAGS)
++AC_SUBST(JANSSON_LIBS)
++
+ PKG_CHECK_MODULES(LIBEVENT, [libevent >= $LIBEVENT_REQUIRED])
+ AC_SUBST(LIBEVENT_CFLAGS)
+ AC_SUBST(LIBEVENT_LIBS)
+diff --git a/net/daemon/Makefile.am b/net/daemon/Makefile.am
+index b8e745f..1321dfc 100644
+--- a/net/daemon/Makefile.am
++++ b/net/daemon/Makefile.am
+@@ -95,7 +95,7 @@ ccnet_SOURCES = ccnet-daemon.c \
+
+ ccnet_LDADD = @LIBEVENT_LIBS@ $(top_builddir)/lib/libccnetd.la \
+ @GLIB2_LIBS@ @GOBJECT_LIBS@ @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ -lsqlite3 \
+- @LIB_WS32@ @LIB_INTL@ @LIB_IPHLPAPI@ @SEARPC_LIBS@
++ @LIB_WS32@ @LIB_INTL@ @LIB_IPHLPAPI@ @SEARPC_LIBS@ @JANSSON_LIBS@
+
+
+ ccnet_LDFLAGS = @STATIC_COMPILE@ @CONSOLE@ @SERVER_PKG_RPATH@ -no-undefined
+@@ -106,7 +106,7 @@ ccnet_test_SOURCES = ccnet-test.c daemon-session.c $(common_srcs)
+
+ ccnet_test_LDADD = @LIBEVENT_LIBS@ $(top_builddir)/lib/libccnetd.la \
+ @GLIB2_LIBS@ @GOBJECT_LIBS@ @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ -lsqlite3 \
+- @LIB_WS32@ @LIB_INTL@ @LIB_IPHLPAPI@ @SEARPC_LIBS@
++ @LIB_WS32@ @LIB_INTL@ @LIB_IPHLPAPI@ @SEARPC_LIBS@ @JANSSON_LIBS@
+
+ ccnet_test_LDFLAGS = @STATIC_COMPILE@ -no-undefined @CONSOLE@
+
+diff --git a/net/server/Makefile.am b/net/server/Makefile.am
+index da98420..867a1ff 100644
+--- a/net/server/Makefile.am
++++ b/net/server/Makefile.am
+@@ -103,7 +103,7 @@ ccnet_server_LDADD = @LIBEVENT_LIBS@ $(top_builddir)/lib/libccnetd.la \
+ @GLIB2_LIBS@ @GOBJECT_LIBS@ @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ -lsqlite3 \
+ -lpthread \
+ @LIB_WS32@ @LIB_INTL@ @LIB_IPHLPAPI@ @SEARPC_LIBS@ @ZDB_LIBS@ \
+- @LDAP_LIBS@
++ @LDAP_LIBS@ @JANSSON_LIBS@
+
+
+ ccnet_server_LDFLAGS = @STATIC_COMPILE@ @CONSOLE@ @SERVER_PKG_RPATH@ -no-undefined
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41e8718300b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: julienCXX <archlinux@chmodplusx.eu>
+
+# Contributor: Moritz Maxeiner <moritz@ucworks.org>
+# Contributor: Aaron Lindsay <aaron@aclindsay.com>
+
+pkgname=mingw-w64-ccnet
+pkgver=4.2.3
+pkgrel=4
+pkgdesc="A framework for writing networked applications in C (mingw-w64)."
+arch=('any')
+url="https://github.com/haiwen/ccnet/"
+license=('custom')
+makedepends=('mingw-w64-configure' 'vala>=0.8' 'python2>=2.6')
+depends=('mingw-w64-crt' 'mingw-w64-libevent>=2.0' 'mingw-w64-glib2>=2.26.0'
+'mingw-w64-libsearpc' 'mingw-w64-winpthreads' 'mingw-w64-jansson>=2.2.1'
+'mingw-w64-sqlite' 'mingw-w64-openssl')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("ccnet-${pkgver}.tar.gz::https://github.com/haiwen/ccnet/archive/v${pkgver}.tar.gz"
+ "libccnet.pc.patch"
+ "0001-Add-autoconfiguration-for-libjansson.patch"
+ "ccnet-pull-86.patch::https://patch-diff.githubusercontent.com/raw/haiwen/ccnet/pull/86.patch"
+ "ccnet-pull-87.patch::https://patch-diff.githubusercontent.com/raw/haiwen/ccnet/pull/87.patch")
+sha256sums=('7da578ed4b04b99673c711cf22a9dc535e31c6f323e5701348211129be48c92d'
+ '66c3b02c3981db6a80819e0ae103bedadf8dfdf81405a7f75a9cba714acf973f'
+ '382b1da33e2b6c0ebab8d3921d92b7417fa11d969ad822cd43aee499fd7b3d94'
+ 'b5c4cea9c718cf0e2e32572068ec9da4dc26cac7cfc1597eceff4aa53a4d0156'
+ '1ea5f5555c6472afcbf6ad58b0ebdd86e5b58db0a848576f8b74c100083a8b7d')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "$srcdir/ccnet-$pkgver"
+ patch -p1 -i "$srcdir"/libccnet.pc.patch
+ patch -p1 -i "$srcdir"/0001-Add-autoconfiguration-for-libjansson.patch
+ # Fix for 64-bit compilation
+ patch -p1 -i "$srcdir"/ccnet-pull-86.patch
+ patch -p1 -i "$srcdir"/ccnet-pull-87.patch
+ # Case fix on includes
+ sed -i 's/<Rpc.h>/<rpc.h>/g' lib/libccnet_utils.c
+ sed -i 's/<Rpc.h>/<rpc.h>/g' lib/utils.c
+}
+
+build() {
+ cd "$srcdir/ccnet-$pkgver"
+
+ # Required for the build process to find searpc-codegen.py
+ export PATH=/usr/i686-w64-mingw32/bin/:"$PATH"
+
+ ./autogen.sh
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ cp -r ../lib/ lib
+ ${_arch}-configure --enable-compile-demo=no PYTHON=python2
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/ccnet-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/usr/"$_arch"/lib/python2.7/site-packages/
+ mv "$pkgdir"/Lib/site-packages/* "$pkgdir"/usr/"$_arch"/lib/python2.7/site-packages/
+ rm -rf "$pkgdir"/Lib
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.{dll,exe}
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+ done
+}
+
diff --git a/libccnet.pc.patch b/libccnet.pc.patch
new file mode 100644
index 000000000000..dcc95e4be272
--- /dev/null
+++ b/libccnet.pc.patch
@@ -0,0 +1,8 @@
+--- a/libccnet.pc.in 2013-01-10 01:35:24.000000000 -0500
++++ b/libccnet.pc.in 2013-01-19 11:31:50.479301798 -0500
+@@ -1,4 +1,4 @@
+-prefix=(DESTDIR)@prefix@
++prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@