summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-08-25 23:30:37 +0200
committerMichel Zou2017-08-25 23:30:37 +0200
commit6def26be71879739eb70bc27941d7b0866591f8d (patch)
treead50efe24532ec6eaab15875999f19a6fa0cf107
parent5b7a48d12857b071a5437cede50437b18cee6c40 (diff)
downloadaur-6def26be71879739eb70bc27941d7b0866591f8d.tar.gz
3.3.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74c6843cc0e0..04901be66509 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jun 25 06:44:37 UTC 2017
+# Fri Aug 25 21:30:37 UTC 2017
pkgbase = mingw-w64-cgns
pkgdesc = Standard for recording and recovering computer data associated with the numerical solution of fluid dynamics equations (mingw-w64)
- pkgver = 3.3.0
+ pkgver = 3.3.1
pkgrel = 1
url = http://www.cgns.org
arch = any
@@ -13,8 +13,8 @@ pkgbase = mingw-w64-cgns
options = !buildflags
options = !strip
options = staticlibs
- source = mingw-w64-cgns-3.3.0.tar.gz::https://github.com/CGNS/CGNS/archive/v3.3.0.tar.gz
- sha256sums = 8422c67994f8dc6a2f201523a14f6c7d7e16313bdd404c460c16079dbeafc662
+ source = mingw-w64-cgns-3.3.1.tar.gz::https://github.com/CGNS/CGNS/archive/v3.3.1.tar.gz
+ sha256sums = 81093693b2e21a99c5640b82b267a495625b663d7b8125d5f1e9e7aaa1f8d469
pkgname = mingw-w64-cgns
diff --git a/PKGBUILD b/PKGBUILD
index 259cd71281e5..fd3cf38fab16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-cgns
_PKGNAME=CGNS
-pkgver=3.3.0
+pkgver=3.3.1
pkgrel=1
pkgdesc='Standard for recording and recovering computer data associated with the numerical solution of fluid dynamics equations (mingw-w64)'
arch=('any')
@@ -10,17 +10,15 @@ depends=('mingw-w64-crt' 'mingw-w64-hdf5')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/${_PKGNAME}/${_PKGNAME}/archive/v${pkgver}.tar.gz)
-sha256sums=('8422c67994f8dc6a2f201523a14f6c7d7e16313bdd404c460c16079dbeafc662')
+sha256sums=('81093693b2e21a99c5640b82b267a495625b663d7b8125d5f1e9e7aaa1f8d469')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare(){
cd "${srcdir}/${_PKGNAME}-${pkgver}"
- # https://github.com/CGNS/CGNS/pull/41
- sed -i "s| _declspec| __declspec|g" src/cgnslib.h src/cgns_io.h src/cgns_header.h src/adf/ADF.h src/cgio_ftoc.c
- sed -i "s|RUNTIME DESTINATION lib|RUNTIME DESTINATION bin|g" src/CMakeLists.txt
- sed -i "72,77d" src/tools/CMakeLists.txt
+ # https://github.com/CGNS/CGNS/pull/45
+ sed -i "s|#ifdef CG_BUILD_64BIT|#if 0|g" src/cgnstypes.h.in
}
build() {
@@ -28,7 +26,7 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- if test "$_arch" = "x86_64-w64-mingw32"
+ if test "${_arch}" = "x86_64-w64-mingw32"
then
_64bits=ON
else
@@ -42,7 +40,6 @@ build() {
-DCGNS_ENABLE_LEGACY:BOOL=ON \
-DCGNS_ENABLE_SCOPING:BOOL=OFF \
-DCGNS_ENABLE_TESTS:BOOL=OFF \
- -DCMAKE_BUILD_TYPE:STRING="Release" \
..
make
popd