summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Schneider2020-03-28 14:47:51 +0100
committerViktor Schneider2020-03-28 14:47:51 +0100
commit607f090bd2d2cdc2a6dbbb672b49b329b9c12c69 (patch)
treecedd51da2d4d9d5c66dcfdd0bed97fe6ac7e256a
parentbbe1334f7935eec0bf1718e239c0eb72067c4cc6 (diff)
downloadaur-607f090bd2d2cdc2a6dbbb672b49b329b9c12c69.tar.gz
apply patch to install cmake target files correctly
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--use-correct-path-for-cmake-files.patch15
3 files changed, 25 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc30e425722d..47df91bafff0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-chrono-date
pkgdesc = A date and time library based on the C++11/14/17 <chrono> header
pkgver = 2.4.1+134+g9a0ee25
- pkgrel = 3
+ pkgrel = 4
url = https://howardhinnant.github.io/date/date.html
arch = any
license = MIT
@@ -13,8 +13,10 @@ pkgbase = mingw-w64-chrono-date
options = !buildflags
source = mingw-w64-chrono-date::git+https://github.com/HowardHinnant/date#commit=9a0ee2542848ab8625984fc8cdbfb9b5414c0082
source = 538-output-date-pc-for-pkg-config.patch::https://patch-diff.githubusercontent.com/raw/HowardHinnant/date/pull/538.patch
+ source = use-correct-path-for-cmake-files.patch
sha256sums = SKIP
sha256sums = f39ce7f1f738ebdc02948ed78be68cca10c01f9e22a4243670304eeda53a03fd
+ sha256sums = 0cf34f1c8efa949ba9d3c983d9032c114eaa99c5b5790bc9d5872aaaf0438120
pkgname = mingw-w64-chrono-date
diff --git a/PKGBUILD b/PKGBUILD
index aff2d274cb62..41a82085d366 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mingw-w64-chrono-date
pkgver=2.4.1+134+g9a0ee25
-pkgrel=3
+pkgrel=4
pkgdesc="A date and time library based on the C++11/14/17 <chrono> header"
arch=('any')
url="https://howardhinnant.github.io/date/date.html"
@@ -23,9 +23,11 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
# https://github.com/Alexays/Waybar/issues/565) are present with the tagged
# stable version.
source=("$pkgname::git+https://github.com/HowardHinnant/date#commit=9a0ee2542848ab8625984fc8cdbfb9b5414c0082"
- "538-output-date-pc-for-pkg-config.patch::https://patch-diff.githubusercontent.com/raw/HowardHinnant/date/pull/538.patch")
+ "538-output-date-pc-for-pkg-config.patch::https://patch-diff.githubusercontent.com/raw/HowardHinnant/date/pull/538.patch"
+ "use-correct-path-for-cmake-files.patch")
sha256sums=('SKIP'
- 'f39ce7f1f738ebdc02948ed78be68cca10c01f9e22a4243670304eeda53a03fd')
+ 'f39ce7f1f738ebdc02948ed78be68cca10c01f9e22a4243670304eeda53a03fd'
+ '0cf34f1c8efa949ba9d3c983d9032c114eaa99c5b5790bc9d5872aaaf0438120')
pkgver() {
cd "$pkgname"
@@ -36,6 +38,8 @@ prepare() {
cd "$pkgname"
# https://github.com/HowardHinnant/date/issues/537
patch -p1 < ../538-output-date-pc-for-pkg-config.patch
+
+ patch -p1 < ../use-correct-path-for-cmake-files.patch
}
build() {
@@ -69,8 +73,6 @@ package() {
cd "$pkgname"
for _arch in ${_architectures}; do
make -C build-${_arch} DESTDIR="$pkgdir/" install
- install -d 755 "$pkgdir/usr/${_arch}/lib/cmake"
- mv "$pkgdir/usr/${_arch}/CMake" "$pkgdir/usr/${_arch}/lib/cmake/date"
done
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
diff --git a/use-correct-path-for-cmake-files.patch b/use-correct-path-for-cmake-files.patch
new file mode 100644
index 000000000000..c4647694b154
--- /dev/null
+++ b/use-correct-path-for-cmake-files.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt 2020-03-28 14:38:50.126178670 +0100
++++ b/CMakeLists.txt 2020-03-28 14:39:30.323094276 +0100
+@@ -167,11 +167,7 @@
+ export( TARGETS tz NAMESPACE date:: APPEND FILE dateTargets.cmake )
+ endif( )
+
+-if( WIN32 AND NOT CYGWIN)
+- set( CONFIG_LOC CMake )
+-else( )
+- set( CONFIG_LOC "${CMAKE_INSTALL_LIBDIR}/cmake/date" )
+-endif( )
++set( CONFIG_LOC "${CMAKE_INSTALL_LIBDIR}/cmake/date" )
+ install( EXPORT dateConfig
+ FILE dateTargets.cmake
+ NAMESPACE date::