summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-11-07 22:37:17 +0100
committerMichel Zou2020-11-07 22:37:17 +0100
commit25e47eddfb78ce6b1240073ef90093c2a8235c38 (patch)
treebc0281725e75ede53d5d82245dc0fab531ee67c6
parent1a6a4151c62cb69800d2f61781a8953cc13b560b (diff)
downloadaur-25e47eddfb78ce6b1240073ef90093c2a8235c38.tar.gz
QT_HOST_PATH
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
-rw-r--r--mingw-cmake-py.sh8
-rw-r--r--toolchain-mingw.cmake1
4 files changed, 4 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a8c93f867c7..05f96b9a730f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-cmake
pkgdesc = CMake wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 34
+ pkgrel = 35
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = GPL
@@ -11,7 +11,6 @@ pkgbase = mingw-w64-cmake
depends = mingw-w64-environment
optdepends = mingw-w64-wine: runtime support
source = mingw-cmake.sh
- source = mingw-cmake-py.sh
source = toolchain-mingw.cmake
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2b73134452e6..2237ea33ffa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
-
pkgname=mingw-w64-cmake
pkgver=1
-pkgrel=34
+pkgrel=35
arch=('any')
pkgdesc="CMake wrapper for MinGW (mingw-w64)"
depends=('cmake' 'mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-environment')
@@ -9,19 +8,15 @@ optdepends=('mingw-w64-wine: runtime support')
license=("GPL")
url="http://fedoraproject.org/wiki/MinGW"
source=("mingw-cmake.sh"
- "mingw-cmake-py.sh"
"toolchain-mingw.cmake")
sha256sums=('SKIP' 'SKIP' "SKIP")
+
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-_python_versions="27 36 37 38"
build() {
for _arch in ${_architectures}; do
sed "s|@TRIPLE@|${_arch}|g;s|@PROCESSOR@|${_arch::-12}|g" toolchain-mingw.cmake > toolchain-${_arch}.cmake
sed "s|@TRIPLE@|${_arch}|g" mingw-cmake.sh > ${_arch}-cmake
- for _pyver in ${_python_versions}; do
- sed "s|@TRIPLE@|${_arch}|g;s|@PYMAJMIN@|${_pyver}|g" mingw-cmake-py.sh > ${_arch}-cmake-py${_pyver}
- done
done
}
diff --git a/mingw-cmake-py.sh b/mingw-cmake-py.sh
deleted file mode 100644
index 641c9c302b22..000000000000
--- a/mingw-cmake-py.sh
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-mingw_prefix=/usr/@TRIPLE@
-
-@TRIPLE@-cmake \
- -DPYTHON_INCLUDE_DIR=${mingw_prefix}/include/python@PYMAJMIN@ \
- -DPYTHON_LIBRARY=${mingw_prefix}/lib/libpython@PYMAJMIN@.dll.a \
- -DPYTHON_EXECUTABLE=/usr/bin/@TRIPLE@-python@PYMAJMIN@-bin \
- "$@"
diff --git a/toolchain-mingw.cmake b/toolchain-mingw.cmake
index 6e0136a9013a..c99b33e55686 100644
--- a/toolchain-mingw.cmake
+++ b/toolchain-mingw.cmake
@@ -18,6 +18,7 @@ set (CMAKE_FIND_ROOT_PATH_MODE_PACKAGE ONLY)
# Make sure Qt can be detected by CMake
set (QT_BINARY_DIR /usr/@TRIPLE@/bin /usr/bin)
set (QT_INCLUDE_DIRS_NO_SYSTEM ON)
+set (QT_HOST_PATH "/usr" CACHE PATH "host path for Qt")
# set the resource compiler (RHBZ #652435)
set (CMAKE_RC_COMPILER @TRIPLE@-windres)